zoukankan      html  css  js  c++  java
  • ZOJ1586:QS Network (最小生成树)

    QS Network

    题目链接http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1586

    Description:

    In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

    A sample is shown below:


    A sample QS network, and QS A want to send a message.

    Step 1. QS A sends message to QS B and QS C;

    Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

    Step 3. the procedure terminates because all the QS received the message.

    Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

    Input:

    The 1st line of the input contains an integer t which indicates the number of data sets.

    From the second line there are t data sets.

    In a single data set,the 1st line contains an interger n which indicates the number of QS.

    The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

    In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

    Constrains:

    all the integers in the input are non-negative and not more than 1000.

    Output:

    for each data set,output the minimum cost in a line. NO extra empty lines needed.

    Sample Input:

    1
    3
    10 20 30
    0 100 200
    100 0 300
    200 300 0

    Sample Output:

    370

    题意:

    给出n个点,每个点都有相应权值,对应边也有相应权值,问将这个图连通的最小花费为多少。

    连一条边的花费为这条边上的权值加上两个端点的权值。

    题解:

    重新计算一下边权然后直接跑最小生成树就行了。

    代码如下:

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <queue>
    using namespace std;
    typedef long long ll;
    const int N =1005;
    int t,n,tot;
    int a[N],mp[N][N];
    struct Edge{
        int u,v,w;
        bool operator < (const Edge &A)const{
            return w<A.w;
        }
    }e[N*N];
    int f[N];
    int find(int x){
        return f[x]==x?f[x]:f[x]=find(f[x]);
    }
    int Kruskal(){
        int ans=0;
        for(int i=0;i<=n+1;i++) f[i]=i;
        for(int i=1;i<=tot;i++){
            int fx=find(e[i].u),fy=find(e[i].v);
            if(fx==fy) continue ;
            f[fx]=fy;
            ans+=e[i].w;
        }
        return ans ;
    }
    int main(){
        cin>>t;
        while(t--){
            scanf("%d",&n);
            tot=0;
            for(int i=1;i<=n;i++) scanf("%d",&a[i]);
            for(int i=1;i<=n;i++){
                for(int j=1;j<=n;j++){
                    scanf("%d",&mp[i][j]);
                    if(j>i){
                        tot++;
                        e[tot].u=i;e[tot].v=j;e[tot].w=mp[i][j]+a[i]+a[j];
                    }
                }
            }
            sort(e+1,e+tot+1);
            cout<<Kruskal()<<endl;
        }
        return 0;
    }
  • 相关阅读:
    SVN的使用
    ajax 显示,删除,批量删除,修改反填功能实现
    Linux 安装软件的几种方式
    《面向对象软件开发实践》笔记一
    Entity Framework 新手入门友好实例
    MIT 计算机科学及编程导论 Python 笔记 1
    JetBrains套装免费学生授权申请(IntelliJ, WebStorm...)
    我的十月
    关于《未成年人网络保护条例(草案征求意见稿)》的意见
    C# 分隔字符串成为字符串数组的方法(保留分隔符)
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/10372057.html
Copyright © 2011-2022 走看看