zoukankan      html  css  js  c++  java
  • UVA:11183:Teen Girl Squad (有向图的最小生成树)

    Teen Girl Squad

    Description:

    You are part of a group of n teenage girls armed with cellphones. You have some news you want to tell everyone in the group. The problem is that no two of you are in the same room, and you must communicate using only cellphones. What’s worse is that due to excessive usage, your parents have refused to pay your cellphone bills, so you must distribute the news by calling each other in the cheapest possible way. You will call several of your friends, they will call some of their friends, and so on until everyone in the group hears the news. Each of you is using a different phone service provider, and you know the price of girl A calling girl B for all possible A and B. Not all of your friends like each other, and some of them will never call people they don’t like. Your job is to find the cheapest possible sequence of calls so that the news spreads from you to all n-1 other members of the group.

    Input:

    The first line of input gives the number of cases, N (N < 150). N test cases follow. Each one starts with two lines containing n (0 ≤ n ≤ 1000) and m (0 ≤ m ≤ 40, 000). Girls are numbered from 0 to n-1, and you are girl 0. The next m lines will each contain 3 integers, u, v and w, meaning that a call from girl u to girl v costs w cents (0 ≤ w ≤ 1000). No other calls are possible because of grudges, rivalries and because they are, like, lame. The input file size is around 1200 KB.

    Output:

    For each test case, output one line containing ‘Case #x:’ followed by the cost of the cheapest method of distributing the news. If there is no solution, print ‘Possums!’ instead.

    Sample Input:

    4 2 1 0 1 10 2 1 1 0 10 4 4 0 1 10 0 2 10 1 3 20 2 3 30 4 4 0 1 10 1 2 20 2 0 30 2 3 100

    Sample Output:

    Case #1: 10

    Case #2: Possums!

    Case #3: 40

    Case #4: 130

    题解:

    有向图的最小生成树模板题,用朱刘算法即可解决。

    代码如下:

    #include<cstdio>
    #include<cmath>
    #include<algorithm>
    #include<iostream>
    #include<cstring>
    #define INF 0x3f3f3f3f
    using namespace std;
    int n,m,t;
    const int N = 1005,M = 40005;
    struct Edge{
        int u,v,w;
    }e[M];
    int pre[N]; //记录前驱.
    int id[N],vis[N],in[N];
    int dirMst(int root){
        int ans=0;
        while(1){
            memset(in,INF,sizeof(in));
            memset(id,-1,sizeof(id));
            memset(vis,-1,sizeof(vis));
            for(int i=1;i<=m;i++){
                int u=e[i].u,v=e[i].v,w=e[i].w;
                if(w<in[v] && v!=u){
                    pre[v]=u;
                    in[v]=w;
                }
            }           //求最小入边集
            in[root]=0;
            pre[root]=root;
            for(int i=0;i<n;i++){
                if(in[i]==INF) return -1;
                ans+=in[i];
            }
            int idx = 0; //新标号
            for(int i=0;i<n;i++){
                if(vis[i] == -1 ){
                    int u = i;
                    while(vis[u] == -1){
                        vis[u] = i;
                        u = pre[u];
                    }
                    if(vis[u]!=i || u==root) continue;     //判断是否形成环
                    for(int v=pre[u];v!=u;v=pre[v] )
                        id[v]=idx;
                    id[u] = idx++;
                }
            }
            if(idx==0) break;
            for(int i=0;i<n;i++){
                if(id[i]==-1) id[i]=idx++;
            }
            for(int i=1;i<=m;i++){
                e[i].w-=in[e[i].v];
                e[i].u=id[e[i].u];
                e[i].v=id[e[i].v];
            }
            n = idx;
            root = id[root];//给根新的标号
        }
        return ans;
    }
    
    int main(){
        cin>>t;
        int cnt = 0;
        while(t--){
            cnt++;
            scanf("%d%d",&n,&m);
            for(int i=1;i<=m;i++)
                scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
            printf("Case #%d: ",cnt);
            int res=dirMst(0);
            if(res==-1) puts("Possums!");
            else cout<<res<<endl;
        }
    }
  • 相关阅读:
    白手起家的亿万富翁马克·库班,既是球队老板又是知名投资人
    放弃事业单位工作,他投身智能产品研发,开办三百家线下体验店
    从一名资深“吃货”到成为59家餐饮店老板,看他怎么成功转变的
    从餐厅的小小服务员成长为中式快餐创始人,看他如何逆袭的
    从摆摊开始,发展成坐拥十多家分店的企业家,看他如何蜕变的
    perl 2维数组转json
    获取 指定pool的成员状态,返回2维数组
    民生银行牛新庄:大数据及分布式技术在银行系统中实践应用
    Mockjs+Ajax实践
    Mockjs+Ajax实践
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/10372428.html
Copyright © 2011-2022 走看看