zoukankan      html  css  js  c++  java
  • UVA315:Network(求割点)

    Network

    题目链接:https://vjudge.net/problem/UVA-315

    Description:

    A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

    Input:

    The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just ‘0’. The last block has only one line with N = 0.

    Output:

    The output contains for each block except the last in the input file one line containing the number of critical places.

    Sample Input:

    5 5 1 2 3 4 0 6 2 1 3 5 4 6 2 0 0

    Sample Output:

    1 2

    题意:

    给出一个无向图,问割点的个数。

    题解:

    就是求割点的模板题,利用时间戳来求,注意最后判断一下根的情况。

    代码如下:

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <queue>
    using namespace std;
    typedef long long ll;
    const int N = 105;
    int n;
    int head[N];
    struct Edge{
        int u,v,next;
    }e[N*N<<2];
    int T,tot;
    int dfn[N],low[N],cut[N];
    void adde(int u,int v){
        e[tot].v=v;e[tot].next=head[u];head[u]=tot++;
    }
    void init(){
        memset(head,-1,sizeof(head));tot=0;
        memset(cut,0,sizeof(cut));T=0;
        memset(dfn,0,sizeof(dfn));
    }
    void Tarjan(int u,int pre){
        dfn[u]=low[u]=++T;
        int son=0;
        for(int i=head[u];i!=-1;i=e[i].next){
            int v=e[i].v;
            if(v==pre) continue ;
    
            if(!dfn[v]){
                son++;
                Tarjan(v,u);
                low[u]=min(low[u],low[v]);
                if(low[v]>=dfn[u]&&u!=pre)cut[u]=1;
            }else{
                low[u]=min(low[u],dfn[v]);
            }
        }
        if(u==pre && son>1) cut[u]=1;
    }
    int main(){
        while(scanf("%d",&n)&&n){
            int u;char ch;
            init();
            while(scanf("%d",&u)&&u){
                int v;
                while(1){
                    scanf("%d%c",&v,&ch);
                    adde(u,v);adde(v,u);
                    if(ch=='
    ') break ;
                }
            }
            for(int i=1;i<=n;i++){
                if(!dfn[i]) Tarjan(i,i);
            }
            int ans = 0;
            for(int i=1;i<=n;i++){
                if(cut[i]) ans++;
            }
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    java面向对象day01
    找工作——JVM内存管理
    找工作——多线程
    找工作-——网络IO
    找工作--volatile
    找工作——异常处理
    找工作--设计模式
    Sqoop安装
    NIO
    Hadoop源码编译
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/10393130.html
Copyright © 2011-2022 走看看