zoukankan      html  css  js  c++  java
  • HDU4738:Caocao's Bridges(求桥)

    Caocao's Bridges

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 8476    Accepted Submission(s): 2604

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4738

    Description:

    Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.

    Input:

    There are no more than 12 test cases.

    In each test case:

    The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N2 )

    Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

    The input ends with N = 0 and M = 0.

    Output:

    For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.

    Sample Input:

    3 3
    1 2 7
    2 3 4
    3 1 4
    3 2
    1 2 7
    2 3 4
    0 0

    Sample Output:

    -1
    4

    题意:

    给出一个无向图,然后每条边都有边权,求所有桥的最小边权。若不存在桥,输出-1。

    题解:

    这个就直接dfs一下,利用时间戳来求桥就行了。但是注意如果边权为0的时候,答案为1。。因为至少需要一个人去搬炸弹。

    代码如下:

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <queue>
    using namespace std;
    typedef long long ll;
    const int N = 1005;
    int n,m,tot;
    int head[N];
    struct Edge{
        int u,v,next,w;
    }e[N*N<<1];
    int T;
    int dfn[N],low[N],cut[N*N];
    void adde(int u,int v,int w){
        e[tot].u=u;e[tot].v=v;e[tot].w=w;e[tot].next=head[u];head[u]=tot++;
    }
    void init(){
        T=0;tot=0;
        memset(head,-1,sizeof(head));
        memset(cut,0,sizeof(cut));
        memset(dfn,0,sizeof(dfn));
    }
    void Tarjan(int u,int pre){
        dfn[u]=low[u]=++T;
        int k = 0;
        for(int i=head[u];i!=-1;i=e[i].next){
            int v=e[i].v;
            if(v==pre &&!k){
                k=1;
                continue ;
            }
            if(!dfn[v]){
                Tarjan(v,u);
                low[u]=min(low[u],low[v]);
            }else{
                low[u]=min(low[u],dfn[v]);
            }
            if(low[v]>dfn[u]){
                cut[i]=cut[i^1]=1;
            }
        }
    }int main(){
        while(scanf("%d%d",&n,&m)!=EOF){
            if(n+m<=0) break;
            init();
            for(int i=1;i<=m;i++){
                int u,v,w;
                scanf("%d%d%d",&u,&v,&w);
                adde(u,v,w);adde(v,u,w);
            }
            int cnt = 0;
            for(int i=1;i<=n;i++){
                if(!dfn[i]){
                    Tarjan(i,i);
                    cnt++;
                }
            }
            if(cnt>1){
                cout<<0<<endl;
                continue ;
            }
            int ans = 0x3f3f3f3f;
            for(int i=0;i<tot;i+=2){
                if(cut[i])ans=min(ans,e[i].w);
            }
            if(ans==0x3f3f3f3f) puts("-1");
            else cout<<max(ans,1)<<endl;
        }
        return 0;
    }
  • 相关阅读:
    [windbg] 进程、线程
    [Windows 驱动开发] 驱动中获取函数地址
    [DuiLib] 入坑资料收集
    [Windows 驱动开发] 获取驱动详细信息
    基于模板的SPS展示层定制
    关于工作角色的一个新的思考
    中小企业IT建设的有关思路
    定制SharePoint Portal之去除帮助链接
    大客户谈判技巧关于IT行业售前工作
    细节决定成败
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/10421921.html
Copyright © 2011-2022 走看看