zoukankan      html  css  js  c++  java
  • POJ2975:Nim(Nim博弈)

    Nim

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7279   Accepted: 3455

    题目链接:http://poj.org/problem?id=2975

    Description:

    Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

    A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

    Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

     111
    1011
    1101

    There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

    Input:

    The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

    Output:

    For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

    Sample Input:

    3
    7 11 13
    2
    1000000000 1000000000
    0

    Sample Output:

    3
    0

    题意:

    给出n堆石子,每堆都有相应个数,最后问先手一开始有多少种取子方式能够取得最终的胜利。

    题解:

    判断下异或和和ai异或起来和ai的关系就行了。

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <cmath>
    using namespace std;
    typedef long long ll;
    const int N = 2e5+5;
    int n;
    ll a[N];
    int main(){
        ios::sync_with_stdio(false);cin.tie(0);
        while(cin>>n && n){
            ll x = 0;
            for(int i=1;i<=n;i++) cin>>a[i],x^=a[i];
            int ans = 0;
            for(int i=1;i<=n;i++){
                if((a[i]^x)<a[i]) ans++;
            }
            cout<<ans<<'
    ';
        }
        return 0;
    }
  • 相关阅读:
    Linux中配置别名
    Linux下的IO监控与分析
    RHEL6 Systemtap 安装笔记
    记一次多事件绑定中自己给自己设置的坑——click,dblclick,mousedown,mousemove,mouseup
    springboot打jar获取不到static静态资源文件问题
    关于springboot默认日志框架Slf4j+logback,自定义Appender问题
    spring 时间格式问题
    springboot 部署到tomcat,获取根路径问题。空格变为%20
    前后端分离 vue+springboot 跨域 session+cookie失效问题
    springboot 部署到tomcat中,项目总是重新部署
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/10574708.html
Copyright © 2011-2022 走看看