zoukankan      html  css  js  c++  java
  • HDU2389:Rain on your Parade(二分图最大匹配+HK算法)

    Rain on your Parade

    Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 655350/165535 K (Java/Others)
    Total Submission(s): 5755    Accepted Submission(s): 1900

    Description:

    You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
    But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
    You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
    Can you help your guests so that as many as possible find an umbrella before it starts to pour?

    Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however.

    Input:

    The input starts with a line containing a single integer, the number of test cases.
    Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= si <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
    The absolute value of all coordinates is less than 10000.

    Output:

    For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.

    Sample Input:

    2
    1
    2
    1 0 3
    3 0 3
    2
    4 0
    6 0
    1
    2
    1 1 2
    3 3 2
    2
    2 2
    4 4

    Sample Output:

    Scenario #1:
    2

    Scenario #2:
    2

    题意:

    给出客人和雨伞的二维坐标,知道几分钟后下雨以及客人的移动速度,问可以拿到雨伞最多有多少人。

    题解:

    将客人与其可以到达的雨伞连边,进行二分图的最大匹配即可。

    但这题比较坑的地方就是数据量较大,匈牙利算法会超时(好像很少有题会卡匈牙利算法........),所以就应该用匈牙利算法的优化版:HK算法。

    HK算法的思想就是先通过bfs预处理出最小增光路集,然后dfs增广的时候就把这些增广路集一并增广。

    具体的算法分析可以看看这个:http://files.cnblogs.com/files/liuxin1.pdf

    直接上代码~~

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <cmath>
    #include <queue> 
    using namespace std;
    const int N = 3005 ;
    int T,t,n,m,ans,lim,cnt=0;
    int d[N][N],link[N][N],match[N],match2[N],check[N],disx[N],disy[N];
    struct guests{
        int x,y,v;
    }g[N];
    inline void init(){
        memset(link,0,sizeof(link));memset(match,-1,sizeof(match));
        ans=0;cnt++;memset(check,0,sizeof(check));memset(match2,-1,sizeof(match2));
    }
    inline int dfs(int x){
        for(int i=1;i<=n;i++){
            if(disy[i]==disx[x]+1 && !check[i] &&link[x][i]){
                check[i]=1;
                if(match[i]!=-1 && disy[i]==lim) continue ;//此时增广路会大于lim 
                if(match[i]==-1 || dfs(match[i])){
                    match[i]=x;
                    match2[x]=i;
                    return 1;
                }
            }
        }
        return 0;
    }
    inline bool bfs(){
        queue<int> q;
        memset(disx,-1,sizeof(disx));
        memset(disy,-1,sizeof(disy));lim = (1<<30);
        for(int i=1;i<=m;i++) if(match2[i]==-1){
            q.push(i);disx[i]=0;
        }
        while(!q.empty()){
            int u=q.front();q.pop();
            if(disx[u]>lim) break ; //条件成立,所求增广路必然比当前的增广路长度长 
            for(int i=1;i<=n;i++){
                if(link[u][i] && disy[i]==-1){
                    disy[i]=disx[u]+1;
                    if(match[i]==-1) lim=disy[i];//找到增广路,记录长度 
                    else{
                        disx[match[i]]=disy[i]+1;
                        q.push(match[i]);//入队,寻找更长的增广路 
                    }
                }
            }
        }
        return lim!=(1<<30) ;
    }
    int main(){
        scanf("%d",&T);
        while(T--){
            init();
            scanf("%d%d",&t,&m);
            for(int i=1;i<=m;i++){
                scanf("%d%d%d",&g[i].x,&g[i].y,&g[i].v);
            }
            scanf("%d",&n);
            for(int i=1,x,y;i<=n;i++){
                scanf("%d%d",&x,&y);
                for(int j=1;j<=m;j++){
                    d[j][i]=abs(g[j].x-x)+abs(g[j].y-y);
                    if(d[j][i]<=t*g[j].v) link[j][i]=1;
                }
            }
            while(bfs()){
                memset(check,0,sizeof(check));
                for(int i=1;i<=m;i++){
                    if(dfs(i)) ans++;
                }
            }
            printf("Scenario #%d:
    %d
    
    ",cnt,ans);
        }
        
        return 0;
    }
  • 相关阅读:
    Nginx编译安装及平滑升级
    alertmanager 分组,抑制, 静默
    alertmanager 邮件告警&自定义告警模板
    alertmanager 高可用
    程序运行报错UnicodeDecodeError: 'utf8' codec can't decode byte 0x89 in position 0: invalid start byte
    Postman 导入curl 、导出成curl、导出成对应语言代码
    Python 字符串操作(截取/替换/查找/分割)
    In testLogin: indirect fixture *** doesn‘t exist
    postman 传参传递二进制流文件
    开发经验01
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/9917183.html
Copyright © 2011-2022 走看看