zoukankan      html  css  js  c++  java
  • POJ1700:Crossing River(过河问题)

                      POJ1700

    题目链接:http://poj.org/problem?id=1700
    Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
     

    Description

    A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

    Output

    For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

    Sample Input

    1
    4
    1 2 5 10
    

    Sample Output

    17

    题解:

    这是一个过河坐船问题,一共有两个策略
    ①最快和次快过去,最快回;最慢和次慢过去,次快回,最快的和次快的过去,t1=a[1]+a[0]+a[n-1]+a[1]+a[1]。②最快和最慢过去,最快回;最快和次快过去,最快回,最快的和次慢的过去,t2=a[n-1]+a[0]+a[1]+a[0]+a[n-2]。选择两者中用时较少的一个策略执行,判断t1与t2大小,只需要判断2a[1]是否大于a[0]+a[n-2],如此便将最慢和次慢送过河,对剩下n-2个人循环处理。注意当n=1、n=2、n=3时直接相加处理即可.
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n,a[1006];
    int main()
    {
        int t,i;
        cin>>t;
        while(t--)
        {
            int f=0;
            //每次f归0
            cin>>n;
    
            for(i=1;i<=n;i++)
                cin>>a[i];
                sort(a,a+n+1);
                while(n)
                {
                    if(n==1)
                    {
                        f+=a[1];
                        break;
                    }
                    if(n==2)
                    {
                        f+=a[2];
                        break;
                    }
                    if(n==3)
                    {
                        f+=a[1]+a[2]+a[3];
                        break;
                    }
                    if(n>3)
                    {
                        if(2*a[2]>(a[1]+a[n-1]))
                            f+=2*a[1]+a[n]+a[n-1];
                        else
                            f+=2*a[2]+a[1]+a[n];
                        n=n-2;
                        //注意循环
                    }
                }
                cout<<f<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Spring中的注解@Service @Component @Controller @Repository区别
    hibhibernate中hql中的语句where语句查询List出现空
    转-sql中的case when的用法
    转-JS子窗口创建父窗口操作父窗口
    JS子父窗口互相取值赋值详解介绍
    转-JS之Window对象
    转-JS中document对象详解
    java设计优化--装饰者模式
    Java继承中属性、方法和对象的关系
    利用Ant脚本生成war包的详细步骤
  • 原文地址:https://www.cnblogs.com/hfc-xx/p/4659294.html
Copyright © 2011-2022 走看看