zoukankan      html  css  js  c++  java
  • HDU1372:Knight Moves(经典BFS题)

                                              HDU1372:Knight Moves(BFS)

     
    Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
     

    Description

     

    A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

    Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

    Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

    Input Specification

    The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

    Output Specification

    For each test case, print one line saying "To get from xx to yy takes n knight moves.".

    Sample Input

    e2 e4
    a1 b2
    b2 c3
    a1 h8
    a1 h7
    h8 a1
    b1 c3
    f6 f6

    Sample Output

    To get from e2 to e4 takes 2 knight moves.
    To get from a1 to b2 takes 4 knight moves.
    To get from b2 to c3 takes 2 knight moves.
    To get from a1 to h8 takes 6 knight moves.
    To get from a1 to h7 takes 5 knight moves.
    To get from h8 to a1 takes 6 knight moves.
    To get from b1 to c3 takes 1 knight moves.
    To get from f6 to f6 takes 0 knight moves.

    题解:骑士走日,和中国象棋中的马一样走日。

      广搜bfs就可以

    AC代码:

    #include <iostream>
    #include <queue>
    #include<string.h>
    using namespace std;
    int s1,s2,e1,e2;
    int tu[8][8];
    int xx[8] = {1, 2, 1, 2, -1, -2, -1, -2};//x坐标变化
    int yy[8] = {2, 1, -2, -1, 2, 1, -2, -1};//y坐标变化
    int bfs()
    {
        memset(tu,0,sizeof(tu));//数组值全为0
        queue<int> q;
        int x1,y1,x2,y2;
        tu[s1][s2]=0;//
        q.push(s1);
        q.push(s2);
        while(!q.empty())
        {
            x1=q.front();
            q.pop();
            y1=q.front();
            q.pop();
            if(x1==e1&&y1==e2)//在原地不动
                return tu[x1][y1];
            for(int i=0; i<8; i++)
            {
                x2=x1+xx[i];
                y2=y1+yy[i];
                if(x2<0||x2>7||y2<0||y2>7||tu[x2][y2]>0)
                    continue;
                tu[x2][y2]=tu[x1][y1]+1;
                q.push(x2);
                q.push(y2);
            }
        }
        return 0;
    }
    int main()
    {
        char a[3],b[3];
        int total;
        while(cin>>a>>b)
        {
            s1=a[0]-'a';//输入的字母,是列,从第一列a开始,减去'a',转换
            s2=a[1]-'1';//输入的数字,是行,从的第一行开始,减去'1',转换
            e1=b[0]-'a';
            e2=b[1]-'1';
            total=bfs();
            cout<<"To get from "<<a<<" to "<<b<<" takes "<<total<<" knight moves."<<endl;
        }
        return 0;
    }
  • 相关阅读:
    js代码的执行顺序及运算
    javascript讲解
    浏览器的差距
    标准流
    下拉列表
    单位
    滚动标签
    接着说一些有关排版的一些东西
    关于处理浏览器的兼容问题
    关于排版的技巧
  • 原文地址:https://www.cnblogs.com/hfc-xx/p/4668619.html
Copyright © 2011-2022 走看看