zoukankan      html  css  js  c++  java
  • C题

    C - C
    Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
     

    Description

     

    Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d<tex2html_verbatim_mark> distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d<tex2html_verbatim_mark> .

    We use Cartesian coordinate system, defining the coasting is the x<tex2html_verbatim_mark> -axis. The sea side is above x<tex2html_verbatim_mark> -axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x<tex2html_verbatim_mark> - y<tex2html_verbatim_mark>coordinates.

    epsfbox{p2519.eps}<tex2html_verbatim_mark>

    Input

    The input consists of several test cases. The first line of each case contains two integers n<tex2html_verbatim_mark>(1$ le$n$ le$1000)<tex2html_verbatim_mark> and d<tex2html_verbatim_mark> , where n<tex2html_verbatim_mark> is the number of islands in the sea and d<tex2html_verbatim_mark> is the distance of coverage of the radar installation. This is followed by n<tex2html_verbatim_mark> lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

    The input is terminated by a line containing pair of zeros.

    Output

    For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. `-1' installation means no solution for that case.

    Sample Input

    3 2
    1 2
    -3 1
    2 1
    
    1 2
    0 2
    
    0 0
    

    Sample Output

    Case 1: 2
    Case 2: 1


    题解:求给出的点,雷达最少有几个才能完全覆盖。

    #include<stdio.h>
    #include<iostream>
    #include<math.h>
    #include<algorithm>
    using namespace std;
    struct node
    {
        double l,r;
    };
    node a[1010];
    int cmp(node a,node b)
    {
        return a.l<b.l;
    }
    int main()
    {
        int n,d;
        int x,y,f,t;
        int s=0;
        while(cin>>n>>d&&n&&d)
        {
            f=1;
            t=1;
            s++;
            for(int i=0; i<n; i++)
            {
                cin>>x>>y;
                if(y>d)f=0;
                else
                {
                    a[i].l=(double)x-sqrt((double)d*d-y*y);
                    a[i].r=(double)x+sqrt((double)d*d-y*y);
                }
            }
            if(f==0)
            {
                cout<<"Case "<<s<<": -1"<<endl;
                continue;
            }
            sort(a,a+n,cmp);
            double p=a[0].r;
            for(int i=1; i<n; i++)
            {
    
                if(a[i].r<p)
                    p=a[i].r;
                else if(p<a[i].l)
                {
                    p=a[i].r;
                    t++;
                }
            }
            cout<<"Case "<<s<<": "<<t<<endl;
    
        }
        return 0;
    }
    View Code


  • 相关阅读:
    NOJ-1581 筷子 (线性DP)
    UVA-242 Stamps and Envelope Size (DP)
    POJ 1860 (SPFA判断正环)
    POJ 3268 最短路水题
    STL----priority_queue
    STL----unique
    POJ 2031(最小生成树Kruskal算法+几何判断)
    POJ 3468(线段树区间修改+区间求和)
    学习线段树
    POJ 1251(最小生成树裸题)
  • 原文地址:https://www.cnblogs.com/hfc-xx/p/4717224.html
Copyright © 2011-2022 走看看