zoukankan      html  css  js  c++  java
  • HDU 2955(0-1背包问题)

    M - 01背包
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
     

    Description

    The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 


    For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


    His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
     

    Input

    The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
    Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
     

    Output

    For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

    Notes and Constraints 
    0 < T <= 100 
    0.0 <= P <= 1.0 
    0 < N <= 100 
    0 < Mj <= 100 
    0.0 <= Pj <= 1.0 
    A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
     

    Sample Input

    3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
     

    Sample Output

    2 4 6
     
     
    题解:同样是0-1背包问题,就是偷到最多的钱不被抓

    1. f[j] = max(f[j],f[j - mj[i]] * (1 - pj[i])); f[j]表示偷到j钱不被抓的概率 
    2. 银行钱数的总和是容量   偷到的钱是价值  被抓到的概率是重量 
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    double pj[105],f[10100],p;
    int mj[105];
    int t,n,total;
    int main()
    {
        cin>>t;
        while(t--)
        {
            cin>>p>>n;
            total=0;
            for(int i=0; i<n; i++)
            {
                cin>>mj[i]>>pj[i];
                total+=mj[i];
            }
             memset(f,0,sizeof(f));
            f[0]=1;
            for(int i=0; i<n; i++)
                for(int j=total; j>=mj[i]; j--)
                {
                    f[j]=max(f[j],f[j-mj[i]]*(1-pj[i]));
                }
            for(int i=total; i>=0; i--)
            {
                if(f[i]>1-p)
                {
                    cout<<i<<endl;
                    break;
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    HTML5项目笔记7:使用HTML5 WebStorage API构建与.NET对应的会话机制 Hello
    论设计模式和分析模式
    昨天我做了点什么事情啊?
    时间,时间,还是时间
    人生需要规划
    突然想起今天的博客汇报没写
    昨天看了熊猫大侠
    双休日往往会忘了写日志
    老婆说我是缺心眼!
    要下班了才想起没写报告
  • 原文地址:https://www.cnblogs.com/hfc-xx/p/4723188.html
Copyright © 2011-2022 走看看