zoukankan      html  css  js  c++  java
  • POJ 2250(LCS最长公共子序列)

                             compromise

    Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
     

    Description

    In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do. 

    Therefore the German government requires a program for the following task: 
    Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind). 

    Your country needs this program, so your job is to write it for us.

    Input

    The input will contain several test cases. 
    Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'. 
    Input is terminated by end of file.

    Output

    For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

    Sample Input

    die einkommen der landwirte
    sind fuer die abgeordneten ein buch mit sieben siegeln
    um dem abzuhelfen
    muessen dringend alle subventionsgesetze verbessert werden
    #
    die steuern auf vermoegen und einkommen
    sollten nach meinung der abgeordneten
    nachdruecklich erhoben werden
    dazu muessen die kontrollbefugnisse der finanzbehoerden
    dringend verbessert werden
    #
    

    Sample Output

    die einkommen der abgeordneten muessen dringend verbessert werden

    题解:

    题意:第一眼看,输入的东西有点长啊,仔细读了读,发现就是找到一个最长公共子序列并打印。

    分析:找到最长公共子序列不难,难的是打印它的一条路径。我们知道是用二维数组dp来保存它的匹配数。一旦有匹配的它就会修改后面的值,保证了

    如何一个状态当前的dp数据中是最大的值。为了记录它路径。我们需要用数组t来记录。可以用递归来实现。

    可能这样说太抽象了,附上一张二维图。

    ABCBDAB

    BDCABA

    两个序列,求最长公共子序列。图中就是路径回溯,这就是选择的过程,看懂了它再去看代码吧

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int t[110][110],dp[110][110];
    string a[110],b[110];
    void lcs(int x,int y)
    {
        for(int i=1; i<=x; i++)
            for(int j=1; j<=y; j++)
            {
                if(a[i]==b[j])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                    t[i][j]=1;
                }
                else
                {
                    if(dp[i][j-1]<=dp[i-1][j])
                    {
                        dp[i][j]=dp[i-1][j];
                        t[i][j]=2;
                    }
                    else
                    {
                        dp[i][j]=dp[i][j-1];
                        t[i][j]=3;
                    }
                }
            }
    }
    
    void output(int x,int y)
    {
        if(x==0||y==0)  return;
        if(t[x][y]==1)
        {
            output(x-1,y-1);
            cout<<a[x]<<" ";
        }
        else if(t[x][y]==2)
            output(x-1,y);
        else if(t[x][y]==3)
            output(x,y-1);
    }
    
    int main()
    {
        string s;
        while(cin>>s)
        {
            int m=2,n=1;
            a[1]=s;
            while(cin>>s&&s!="#")
            {
                a[m++]=s;
            }
            while(cin>>s&&s!="#")
            {
                b[n++]=s;
            }
            lcs(m,n);
            output(m,n);
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    好物推荐,码出高效
    C#设置session过期时间
    [C#] Request.QueryString()测试:用html而非asp控件实现简单登录验证并保存值到Session中
    .aspx页面 用html按钮传送数据到 .aspx.cs后台的和“利用Ajax连接aspx与aspx.cs”方法记录
    Visual Studio出现“ 激活远程语言服务器 c#/Visual Basic 语言服务器客户端出错”请运行devenv/log并检查…………“错误解决办法
    解决ubuntu server下屏幕显示不全问题的详解
    关于ubuntu选择desktop版本还是sever版本的一篇随笔
    MAC系统npm安装依赖,报错npm ERR! code ECONNREFUSED
    Linux 常用命令总结
    Mac电脑查询IP
  • 原文地址:https://www.cnblogs.com/hfc-xx/p/4726771.html
Copyright © 2011-2022 走看看