zoukankan      html  css  js  c++  java
  • 第六周 G题

    G - 数论,最大公约数
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
     

    Description

    There is a hill with n holes around. The holes are signed from 0 to n-1. 
    A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 
     

    Input

    The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 
     

    Output

    For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 
     

    Sample Input

    2
    1 2
    2 2
     

    Sample Output

    NO
    YES
     

    题解:只要m,n的最大公约数为1,就没有输出NO,否则输出YES

    #include<iostream>
    using namespace std;
    int gcd(int a,int b)
    {
        return b==0?a:gcd(b,a%b);
    }
    int main()
    {
        int t,m,n;
        cin>>t;
        while(t--)
        {
            cin>>m>>n;
            if(gcd(m,n)==1)
                cout<<"NO"<<endl;
           else
                cout<<"YES"<<endl;
        }
    }
  • 相关阅读:
    BERT 简介 P1_李宏毅
    GAN_P4 Learning from Unpaired Data_李宏毅
    GAN_P3_李宏毅
    Generation P1_李宏毅
    GAN_P2_Theory behind GAN_李宏毅
    李宏毅_Transformer p2
    李宏毅_Transformer p1
    强类型数据集 官方教程
    网页管理系统一
    读张子阳的用户验证自定义IPrincipal和IIdentity有感
  • 原文地址:https://www.cnblogs.com/hfc-xx/p/4739717.html
Copyright © 2011-2022 走看看