zoukankan      html  css  js  c++  java
  • UVA 10763 Foreign Exchange

     
    Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
     

    Description

    Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has sky-rocketed and now you need assistance with your task.

    The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!

    Input

    The input file contains multiple cases. Each test case will consist of a line containing n - the number of candidates (1≤n≤500000), followed by n lines representing the exchange information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate's original location and the candidate's target location respectively. Locations will be represented by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should not be processed.

    Output

    For each test case, print "YES" on a single line if there is a way for the exchange program to work out, otherwise print "NO".

    Sample Input

    10
    1 2
    2 1
    3 4
    4 3
    100 200
    200 100
    57 2
    2 57
    1 2
    2 1
    10
    1 2
    3 4
    5 6
    7 8
    9 10
    11 12
    13 14
    15 16
    17 18
    19 20
    0

    Sample Output

    YES
    NO

    题解:交换生现在是很受欢迎的,现在又一个负责这个的组织,经常会收到一大批的申请表, 申请内容是从A国家到B国家的。对于一批申请表,
    会有各个不同国家申请到另外各个不同的国家, 假设有任意一个申请A到B的,但是没有B到A的申请, 那么这批申请表都不能被处理。

    思路:这其实就是让你查找A和B的出现次数是否相同

    #include <iostream>
    #include<cstring>
    using namespace std;
    int in[500010];
    int main()
    {
        int n,a,b,f;
        while(cin>>n&&n)
        {
             f=0;
             memset(in,0,sizeof(in));
           for(i=0;i<n;i++)
            {
                cin>>a>>b;
                in[a]--;
                in[b]++;
            }
           
            for(i=0; i<500010; i++)
            {
                if(in[i]!=0)
                {
                    f=1;
                    break;
                }
            }
            if(f==0)
                cout<<"YES"<<endl;
            else
                cout<<"NO"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    windows下一些启动服务的命令
    使用命令行启动服务
    无法向会话状态服务器发出会话状态请求转
    SQLServer跨服务器连接的多种方法
    Response.Buffer = True
    UpdatePanel和Jquery冲突
    <iframe>标签自适应高度和宽度
    java判断获取到的中文字符串是否乱码
    MMC不能打开文件C:\WINDOWS\SYSTEM32\inetsrv\iis.msc,如何解决?
    在.NET中用excel导出(概要)
  • 原文地址:https://www.cnblogs.com/hfc-xx/p/4909437.html
Copyright © 2011-2022 走看看