zoukankan      html  css  js  c++  java
  • Find your present (2) (位异或)


    Problem Description
    In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
     
    Input
    The input file will consist of several cases.  Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
     
    Output
                For each case, output an integer in a line, which is the card number of your present.
     
    Sample Input
    5
    1 1 3 2 2
    3
    1 2 1
    0
     
    Sample Output
    3
    2
    Hint
    Hint
    use scanf to avoid Time Limit Exceeded
     
    Author
    8600
     
    Source
    HDU 2007-Spring Programming Contest - Warm Up (1)
     
    Recommend
    8600
     

    题目内存限制:1024K,所以不能简单地用数组存然后再处理。

    这题有一个好的方法—位异或。

     位异或的运算法则吧:

    1、a^b = b^a。

    2、(a^b)^c = a^(b^c)。

    3、a^b^a = b。

    对于一个任意一个数n,它有几个特殊的性质:

    1、0^n = n。

    2、n^n = 0。

    所以可以通过每次异或运算,最后剩下的值就是出现奇数次的那个数字。

     #include <stdio.h> 
    int main() 

        int n,x,ans; 
        while(scanf("%d",&n),n) 
        { 
            ans = 0; 
            while(n--) 
            { 
                scanf("%d",&x); 
                ans ^= x; 
            } 
            printf("%d ",ans); 
        } 
        return 0; 

  • 相关阅读:
    MySQL配置文件
    Linux安装MySQL以及版本说明
    RabbitMQ之Routing(路由有选择的接收)
    RabbitMQ之Publish/Subscribe(发布/订阅)
    RabibitMQ之Work Queues
    RabbitMQ简单生产者消费者(一对一)发送消息
    Linux下安装RabbitMQ
    PyQt5+qtdesigner开发环境配置
    利用sql语句建立全国省市区三级数据库
    完整项目:网上图书商城(一、MySQL数据库设计)未完
  • 原文地址:https://www.cnblogs.com/hfc-xx/p/5236460.html
Copyright © 2011-2022 走看看