zoukankan      html  css  js  c++  java
  • 单调栈(POJ2559)

    Description

    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

    Input

    The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

    Output

    For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

    Sample Input

    7 2 1 4 5 1 3 3
    4 1000 1000 1000 1000
    0
    

    Sample Output

    8
    4000
    题意图给的很明显了,手写栈代码如下
    #include<iostream>
    #include<cstring>
    using namespace std;
    int a[100005],s[100005],w[100005];
    int main()
    {
        int n,x;
        long long ans;
    while(1)
    {
        int p=0;
        ans=0;
        memset(a,0,sizeof(a));
        memset(w,0,sizeof(a));
        memset(s,0,sizeof(s));
        cin>>n;
        if(n==0)
        break;
        for(int i=1;i<=n;i++)
        cin>>a[i];
        a[n+1]=p;
        for(int i=1;i<=n+1;i++)
        {
            if(a[i]>s[p])
        {
                s[++p]=a[i];
            w[p]=1;
        }
        else
        {
            int width=0;
            while(s[p]>a[i])
            {
                width=width+w[p];
                ans=max(ans,(long long )width*s[p]);
                p--;
            }
            s[++p]=a[i],w[p]=width+1;
        }
        }
        cout<<ans<<endl;
    }
     } 

    STL代码

    #include<iostream>
    #include<cstring>
    #include<stack>
    using namespace std;
    
    int main()
    {
        int n,x;
        long long ans;
    while(1)
    {
        int p=0;
        ans=0;
        cin>>n;
        if(n==0)
        break;
        stack< pair <int ,int > >s;
        s.push(make_pair(0,0));
        for(int i=1;i<=n+1;i++)
        {
            if(i==n+1)
            x=0;
            else
            cin>>x;
            if(x>s.top().first)
            s.push(make_pair(x,1));
            else
            {
                int w=0;
                while(s.top().first>x) 
                {
                    w=w+s.top().second;
                    ans=max(ans,(long long )w*(s.top().first));
                    s.pop();
                }
                s.push(make_pair(x,w+1));
            }
        }
        cout<<ans<<endl;
    }
     } 
  • 相关阅读:
    微软RPC技术学习小结
    [COM Interop学习小结]实现一个C#调用C++的示例
    [一个小问题]Mainfest配置文件的version问题小结
    【小结】IIS7下的Http Native Module开发
    Active Sync与IIS7 Classic&Integrated模式,Exchange 2007&2010的关系
    是否能在构造函数,析构函数中抛出异常?
    Trouble Shooting的一些感想(实时补充)
    python中 try、except、finally 的执行顺序
    Hessian怎样实现远程调用
    mysql的三种驱动类型
  • 原文地址:https://www.cnblogs.com/hh13579/p/10805674.html
Copyright © 2011-2022 走看看