zoukankan      html  css  js  c++  java
  • HDU 3579 Hello Kiki

    Hello Kiki

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2223    Accepted Submission(s): 804


    Problem Description
    One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...
    Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
    One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.
     
    Input
    The first line is T indicating the number of test cases.
    Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
    All numbers in the input and output are integers.
    1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi
     
    Output
    For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.
     
    Sample Input
    2
    2
    14 57
    5 56
    5
    19 54 40 24 80
    11 2 36 20 76
     
    Sample Output
    Case 1:
    341
    Case 2:
    5996
     
    Author
    digiter (Special Thanks echo)
     

    两两求线性同余方程。

    #include <iostream>
    #include <string.h>
    #include <stdio.h>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    typedef long long LL;
    const double PI = acos(-1.0);
    
    LL n , _ ,cas = 1 , a[12] , r[12] ;
    
    void e_gcd( LL a ,LL b , LL &d , LL &x, LL &y  )
    {
        if( b == 0 ){ x = 1 , y = 0 , d = a ; return ; }
        e_gcd( b, a%b , d, y ,x ) ;
        y -= x*( a/b );
    }
    
    LL gcd( LL a , LL b ){ return b == 0 ? a : gcd( b , a%b ) ;}
    
    
    void run()
    {
        LL lcm = 1 ;
        cin >> n ;
        for( int i = 0 ; i < n ; ++i ){
            cin >> a[i] ;
            lcm = lcm / gcd( lcm , a[i] ) * a[i] ;
        }
        for( int i = 0 ; i < n ; ++i ){
            cin >> r[i];
        }
        for( int i = 1 ; i < n ; ++i ) {
            LL d , x , y , A = a[0] , B = a[i] , c = r[i] - r[0] ;
            e_gcd(A,B,d,x,y) ;
            if( c % d ) { cout << "-1" <<endl ; return ; }
            LL b1 = B / d ;
            x *= c / d;
            x = ( x % b1 + b1 ) % b1;
            r[0] = a[0] * x + r[0] ;
            a[0] = a[0] *( a[i] / d );
        }
        if( r[0] == 0 )
            cout<< lcm <<endl ;
        else
            cout << r[0] <<endl;
    }
    
    int main()
    {
        #ifdef LOCAL
            freopen("in.txt","r",stdin);
        #endif // LOCAL
        ios::sync_with_stdio(0);
        cin >> _ ;
        while( _-- ){
            cout <<"Case "<< cas++ << ": ";
            run();
        }
    
    }
    only strive for your goal , can you make your dream come true ?
  • 相关阅读:
    Mysql流程控制语句和存储过程
    第七章 MySQL基础
    第六章 操作数据
    第四章 数据库操作
    第三章 使用MySQL图形化工具
    第二章 初识MySQL
    第一章 数据库基础
    Live555源码学习02 ---- 框架
    Live555源码学习01 ---- 编译
    SRS4.0之RTMP转WebRTC02 ---- RTMP推流到SRS
  • 原文地址:https://www.cnblogs.com/hlmark/p/4002699.html
Copyright © 2011-2022 走看看