zoukankan      html  css  js  c++  java
  • HDU 1079 Calendar Game

    Calendar Game



    Problem Description
    Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid. 

    A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game. 

    Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy. 

    For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.
     
    Input
    The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001. 
     
    Output
    Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO". 
     
    Sample Input
    3
    2001 11 3
    2001 11 2
    2001 10 3
     
    Sample Output
    YES
    NO
    NO
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int f[2002][13][32];
    int mon[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
    bool isleap(int y)
    {
        return y%400==0||(y%100!=0&&y%4==0);
    }
    void add1(int& y,int& m,int& d)
    {
        int ty=y,tm=m,td=d;
        if(tm==2&&td==28)
        {
            if(isleap(y))td++;
            else td=1,tm++;
            y=ty,m=tm,d=td;
            return;
        }
        if((td==29&&tm==2)||(td==30&&mon[tm]==30)||(td==31&&mon[tm]==31))
        {
            td=1,tm++;
            if(tm==13)tm=1,ty++;
            y=ty,m=tm,d=td;
            return;
        }
        td++;
        y=ty,m=tm,d=td;
        return;
    }
    bool add2(int& y,int& m,int& d)
    {
        int ty=y,tm=m,td=d;
        if(td==29&&tm==1)
        {
            if(isleap(ty))
            {
                tm++;
                y=ty,m=tm,d=td;
                return 1;
            }
            else return 0;
        }
        if(tm==12)
        {
            ty++,tm=1;
            y=ty,m=tm,d=td;
            return 1;
        }
        tm++;
        if(td>mon[tm])return 0;
        else
        {
            y=ty,m=tm,d=td;
            return 1;
        }
    }
    int jud(int y,int m,int d)
    {
        if(f[y][m][d]!=-1)return f[y][m][d];
        if(y==2001&&m==11&&d==4)return f[y][m][d]=0;
        if(y>2001)return f[y][m][d]=1;
        else if(y==2001&&m>11)return f[y][m][d]=1;
        else if(y==2001&&m==11&&d>4)return f[y][m][d]=1;
        int ty=y,tm=m,td=d;
        add1(ty,tm,td);
        if(jud(ty,tm,td)==0)return f[y][m][d]=1;
        ty=y,tm=m,td=d;
        if(add2(ty,tm,td)&&jud(ty,tm,td)==0)return f[y][m][d]=1;
        return f[y][m][d]=0;
    }
    int main()
    {
        memset(f,-1,sizeof(f));
        int T;
        scanf("%d",&T);
        while(T--)
        {
            int y,m,d;
            scanf("%d%d%d",&y,&m,&d);
            if(jud(y,m,d))puts("YES");
            else puts("NO");
        }
        return 0;
    }
     
     
  • 相关阅读:
    在多个游戏视图间切换环境准备
    精灵动画Animation对话框组成Idle动画的各精灵
    空函数有参函数调用参数的注意事项Swift 1.1语言
    使用NGUINGUI的相关介绍
    ARP侦查工具Netdiscover
    使用recon/domains-hosts/baidu_site模块,枚举baidu网站的子域
    Transform组件C#游戏开发快速入门
    为什么使用BeagleBoneBeagleBone的优点
    Java-JNA调用DLL(转)
    关于IP网段间互访的问题—路由是根本(转)
  • 原文地址:https://www.cnblogs.com/homura/p/5750787.html
Copyright © 2011-2022 走看看