zoukankan      html  css  js  c++  java
  • Elevator

    Elevator

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 59259    Accepted Submission(s): 32539

    Problem Description
    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
     
    Input
    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
     
    Output
    Print the total time on a single line for each test case. 
     
    Sample Input
    1 2 3 2 3 1 0
     
    Sample Output
    17 41

    这题比较简单,下面是我做的答案:

    #include<iostream>

    using namespace std;

    int main()
    {
    int count=0;//几个数
    while(cin>>count)
    {
    if(count==0) break;
    int sum=0;
    int before=0;
    int now=0;
    while(count--)
    {
    cin>>now;
    if(now>before)
    {
    sum+=(now-before)*6+5;
    }
    else
    {
    sum+=(before-now)*4+5;
    }
    before=now;
    }
    cout<<sum<<endl;
    }
    return 0;
    }

     
  • 相关阅读:
    ApacheServer-----关于443端口被占用的解决方法
    《小强与小明》——正在疯传的伟大的故事
    不争万年,只珍朝夕------我的态度
    dubbo搭建
    使用netty的第一个Hello World
    myBatis数据库常用标签
    mysql 索引
    tomcat部署项目的一点心得
    【康托展开】
    初探计算机硬盘
  • 原文地址:https://www.cnblogs.com/honeybusybee/p/5221850.html
Copyright © 2011-2022 走看看