Least Common Multiple
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43071 Accepted Submission(s): 16184
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296
#include<iostream>
using namespace std;
//求最大公约数
int gcd(int a,int b)//a<b
{
if(a==0) return b;
else
return gcd(b%a,a);
}
int main()
{
int instanceCount=0;
cin>>instanceCount;
while(instanceCount--)
{
int count=0;//每行个数
cin>>count;
int lcm=1;
int before=1;
int now=0;
for(int i=1;i<=count;i++)
{
cin>>now;
if(before==now) lcm=before;
if(before>now)
{
lcm=(before/gcd(now,before))*now;
}
else
{
lcm=(now/gcd(before,now))*before;
}
before=lcm;
}
cout<<lcm<<endl;
}
return 0;
}