zoukankan      html  css  js  c++  java
  • PAT Advanced 1078 Hashing (25) [Hash ⼆次⽅探查法]

    题目

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be “H(key) = key % TSize” where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions. Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
    Input Specification:
    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize(<=10^4) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line areseparated by a space.
    Output Specification:
    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one
    line. All the numbers in a line are separated by a space, and there must be no extra space at the end of
    the line. In case it is impossible to insert the number, print “-” instead.
    Sample Input:
    4 4
    10 6 4 15
    Sample Output:
    0 1 4 –

    题目分析

    1. 输入一系列数字存入哈希表,二次探测解决hash冲突,哈希函数为H(key)=(key+step*step)%size,输出key存放在哈希表的下标,如果不能存入输出"-"
    2. the size of hash table必须为质数,如果不是质数,取比不小于size最小质数作为size的值

    解题思路

    1. 用数组作为hash table,标记是否在某下标是否已经存放数字(1表示下标已占用)
    2. 二次探测解决hash冲突,第一次(key+0)%size,第二次key(key+1*1)%size,第三次key(key+2*2)%size....,step取值范围为[0,size-1](step取值范围晴神笔记P217有证明)。注意是H(key)=(key+stepstep)%size,而不是H(key)=key%size+stepstep(会越界)

    知识点

    1. 判断质数
    bool isPrime(int num) {
    	if(num==1)return false; //易错点
    	for(int i=2; i*i<=num; i++) {
    		if(num%i==0)return false;
    	}
    	return true;
    }
    

    易错点

    1. 1不是质数(若将1视为质数,测试点1不通过)

    Code

    Code 01

    #include <iostream>
    using namespace std;
    bool isPrime(int num) {
    	if(num==1)return false;
    	for(int i=2; i*i<=num; i++) {
    		if(num%i==0)return false;
    	}
    	return true;
    }
    int main(int argc,char * argv[]) {
    	int M,N,key;
    	scanf("%d %d",&M,&N);
    	while(!isPrime(M))M++; // M重置为质数 
    	int hash[M]= {0}; // 存放输入数字的标记数组,hash[i]==1表示i位置已存放输入数字,已被占用 
    	for(int i=0; i<N; i++) {
    		scanf("%d", &key);
    		int step=0;
    		while(step<M&&hash[(key+step*step)%M]==1) step++; // 二次探测,查找空闲存放位置 
    		if(i!=0)printf(" ");
    		if(step==M)printf("-"); // 二次探测,没有找到空余位置 
    		else { // 二次探测,查到空余位置 
    			int index = (key+step*step)%M;
    			hash[index]=1;
    			printf("%d", index);
    		}
    	}
    	return 0;
    }
    
  • 相关阅读:
    Codeforces 1037D【BFS】
    hdu 4725 The Shortest Path in Nya Graph 【拆点】+【最短路】
    LightOJ 1074
    POJ1062昂贵的聘礼(经典) 枚举区间 +【Dijkstra】
    POJ 3159 Candies 【差分约束+Dijkstra】
    POJ 3126 Prime Path【BFS】
    ZOJ 1940 Dungeon Master【三维BFS】
    POJ 3279 Fliptile (二进制枚举)
    HDU 2612 find a way 【双BFS】
    POJ 3414 Pot (输出路径)【BFS】
  • 原文地址:https://www.cnblogs.com/houzm/p/12241595.html
Copyright © 2011-2022 走看看