zoukankan      html  css  js  c++  java
  • PAT Advanced 1106 Lowest Price in Supply Chain (25) [DFS,BFS,树的遍历]

    题目

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.
    Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.
    Input Specification:
    Each input file contains one test case. For each case, The first line contains three positive numbers: N(<=10^5), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:
    Ki ID[1] ID[2] … ID[Ki]
    where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.
    Output Specification:
    For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.
    Sample Input:
    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0
    2 6 1
    1 8
    000
    Sample Output:
    1.8362 2

    题目分析

    已知所有非叶子节点的所有子节点,求最短路径(根节点到叶子节点)的层数和该层叶子节点数

    解题思路

    思路 01

    1. dfs遍历树,参数h记录当前节点所在层数,统计所有层叶子结点数
    2. 找出出现叶子节点的最小层,并计算该层价格

    思路 02

    1. dfs遍历树,参数p记录当前节点所在层的价格,min_h记录出现叶子节点的最小层,min_num记录max_p层叶子节点数

    思路 03

    1. bfs遍历树,int h[n]数组记录当前节点所在层,统计所有层叶子结点数
    2. 找出出现叶子节点的最小层,计算该层价格

    思路 04

    1. bfs遍历树,double ps[n]数组记录当前节点所在层的价格,min_h记录出现叶子节点的最小层,min_num记录max_p层叶子节点数

    Code

    Code 01(dfs)

    #include <iostream>
    #include <vector>
    #include <cmath>
    using namespace std;
    const int maxn = 100000;
    vector<int> nds[maxn];
    double p,r;
    int cns[maxn],leaf[maxn],max_h;
    void dfs(int index, int h){
    	max_h=max(max_h,h);
    	if(cns[index]==0){
    		leaf[h]++; //对应层级叶子节点数+1; 
    		return; 
    	}
    	for(int i=0;i<cns[index];i++){
    		dfs(nds[index][i],h+1); 
    	}
    }
    int main(int argc, char * argv[]) {
    	int n,cid;
    	scanf("%d %lf %lf",&n,&p,&r);
    	for(int i=0; i<n; i++) {
    		scanf("%d",&cns[i]);
    		for(int j=0;j<cns[i];j++){
    			scanf("%d",&cid);
    			nds[i].push_back(cid);
    		}
    	}
    	dfs(0,0);
    	int min_h=0;
    	while(min_h<=max_h&&leaf[min_h]==0)min_h++;
    	printf("%.4f %d",p*pow(1+r*0.01,min_h),leaf[min_h]);
    	return 0;
    }
    

    Code 02(dfs 优化版)

    #include <iostream>
    #include <vector>
    #include <cmath>
    using namespace std;
    const int maxn = 100000;
    vector<int> nds[maxn];
    double p,r;
    int cns[maxn],min_num,min_h=99999999;
    void dfs(int index, int h){
    	if(min_h<h){
    		return;
    	}
    	if(cns[index]==0){
    		if(min_h==h){
    			min_num++;
    		}else if(min_h>h){
    			min_h=h;
    			min_num=1;
    		}
    	}
    	for(int i=0;i<cns[index];i++){
    		dfs(nds[index][i],h+1); 
    	}
    }
    int main(int argc, char * argv[]) {
    	int n,cid;
    	scanf("%d %lf %lf",&n,&p,&r);
    	for(int i=0; i<n; i++) {
    		scanf("%d",&cns[i]);
    		for(int j=0;j<cns[i];j++){
    			scanf("%d",&cid);
    			nds[i].push_back(cid);
    		}
    	}
    	dfs(0,0);
    	printf("%.4f %d",p*pow(1+r*0.01,min_h),min_num);
    	return 0;
    }
    

    Code 03(bfs)

    #include <iostream>
    #include <vector>
    #include <queue>
    #include <cmath>
    using namespace std;
    const int maxn=100000;
    vector<int> nds[maxn];
    double p,r;
    int cns[maxn],cnt,max_h,h[maxn],leaf[maxn];
    bool flag;
    void bfs() {
    	queue<int> q;
    	q.push(0);
    	while(!q.empty()) {
    		int now = q.front();
    		q.pop();
    		max_h=max(max_h,h[now]);
    		if(cns[now]==0) {
    			leaf[h[now]]++; //对应层级叶子结点数+1; 
    		} else {
    			for(int i=0; i<cns[now]; i++) {
    				h[nds[now][i]] = h[now]+1;
    				q.push(nds[now][i]);
    			}
    		}
    	}
    }
    int main(int argc,char * argv[]) {
    	int n,k,cid;
    	scanf("%d %lf %lf",&n,&p,&r);
    	for(int i=0; i<n; i++) {
    		scanf("%d",&cns[i]);
    		for(int j=0; j<cns[i]; j++) {
    			scanf("%d",&cid);
    			nds[i].push_back(cid);
    		}
    	}
    	h[0]=0;
    	bfs();
    	int min_h=0;
    	while(min_h<=max_h&&leaf[min_h]==0)min_h++;
    	printf("%.4f %d",p*pow(1+r*0.01,min_h),leaf[min_h]);
    	return 0;
    }
    

    Code 04(bfs 优化版)

    #include <iostream>
    #include <vector>
    #include <queue>
    #include <cmath>
    using namespace std;
    const int maxn=100000;
    vector<int> nds[maxn];
    double p,r;
    int cns[maxn],cnt,min_h=9999999,min_num,h[maxn];
    bool flag;
    void bfs() {
    	queue<int> q;
    	q.push(0);
    	while(!q.empty()) {
    		int now = q.front();
    		q.pop();
    		if(cns[now]==0) {
    			if(min_h>h[now]){
    				min_h=h[now];
    				min_num=1;
    			}else if(min_h==h[now]){
    				min_num++;
    			}
    		} else {
    			for(int i=0; i<cns[now]; i++) {
    				h[nds[now][i]] = h[now]+1;
    				q.push(nds[now][i]);
    			}
    		}
    	}
    }
    int main(int argc,char * argv[]) {
    	int n,k,cid;
    	scanf("%d %lf %lf",&n,&p,&r);
    	for(int i=0; i<n; i++) {
    		scanf("%d",&cns[i]);
    		for(int j=0; j<cns[i]; j++) {
    			scanf("%d",&cid);
    			nds[i].push_back(cid);
    		}
    	}
    	h[0]=0;
    	bfs();
    	printf("%.4f %d",p*pow(1+r*0.01,min_h),min_num);
    	return 0;
    }
    
  • 相关阅读:
    Kafka 再均衡监听器示例
    Spring boot中异步线程池
    【Java&Go并发编程系列】4.等待一组并发任务完成——CountDownLatch VS sync.WaitGroup
    Redis常用命令对应到Redisson对象操作
    Redisson教程
    Redisson官方文档
    Springboot 防止XSS攻击,包含解决RequestBody 的Json 格式参数
    防止XSS脚本注入-前端vue、后端springboot
    在Intellij IDEA中使用Debug
    appium 处理webview
  • 原文地址:https://www.cnblogs.com/houzm/p/12327858.html
Copyright © 2011-2022 走看看