zoukankan      html  css  js  c++  java
  • PAT Advanced 1064 Complete Binary Search Tree (30) [⼆叉查找树BST]

    题目

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The lef subtree of a node contains only nodes with keys less than the node’s key. The right subtree of a node contains only nodes with keys greater than or equal to the node’s key. Both the lef and right subtrees must also be binary search trees. A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from lef to right. Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.
    Input Specification:
    Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
    Output Specification:
    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
    Sample Input:
    10
    1 2 3 4 5 6 7 8 9 0
    Sample Output:
    6 3 8 1 5 7 9 0 2 4

    题目分析

    已知完全二叉查找树的序列,求其层序序列

    解题思路

    思路 01

    1. 输入测试用例,升序排序即为二叉查找树的中序序列
    2. 中序序列递归建树(存储与数组i节点的子节点为2*i,2*i+1,root在1位置)(模拟递归中序遍历过程)
    3. 顺序打印数组即为层序序列

    思路 02

    1. 输入测试用例,升序排序即为二叉查找树的中序序列
    2. 中序序列递归建树(存储与数组i节点的子节点为2i,2i+1,root在1位置)(找root的坐标k,将中序序列划分为startk-1左子树和k+1end右子树)
    3. 顺序打印数组即为层序序列

    知识点

    完全二叉查找树,任意节点序列建树
    注:二叉查找树(不一定要完全二叉树)任意节点序列,升序排序,即为二叉查找树的中序序列

    1. 方式一:模拟递归打印中序序列的过程,将中序序列依次插入到数组建树
    2. 方式二:找root在中序序列中的位置k并将root保存到数组,递归处理startk-1左子树和k+1end右子树,完成建树
    void inOrder(int root) { //root保存在1位置,index初始化为0
    	if(root>n) return;
    	inOrder(root*2);
    	CBT[root]=number[index++];
    	inOrder(root*2+1);
    }
    
    void getLevel(int start, int end, int index) {
    	if(start>end)return;
    	int n=end-start+1;
    	int l=log(n+1)/log(2);//最后一层的层数
    	int leave=n-(pow(2,l)-1); //最后一层叶子结点数
    	//pow(2, l - 1) - 1是除了root结点所在层和最后?层外,左?树的结点个数,pow(2, l - 1) 是l+1
    	//层最多拥有的属于根结点左?树的结点个数,min(pow(2, l - 1), leave)是最后?个结点真正拥有的
    	//属于根结点左?树上的结点个数
    	int root = start+(pow(2,l-1)-1)+min((int)pow(2,l-1),leave);
    	level[index]=in[root];
    	getLevel(start,root-1,2*index+1);
    	getLevel(root+1,end,2*index+2);
    
    }
    

    Code

    Code 01

    #include <iostream>
    #include <algorithm>
    using namespace std;
    const int maxn=1000;
    int n,m;
    int number[maxn],CBT[maxn],index=0;
    void inOrder(int root) {
    	if(root>n) {
    		return;
    	}
    	inOrder(root*2);
    	CBT[root]=number[index++];
    	inOrder(root*2+1);
    }
    int main(int argc,char * argv[]) {
    
    	scanf("%d",&n);
    	for(int i=0; i<n; i++) {
    		scanf("%d",&m);
    		number[i]=m;
    	}
    	// 递增排序--二叉查找树中序序列
    	sort(number,number+n);
    	inOrder(1);//根节点在1位置
    	for(int i=1; i<=n;i++) {
    		if(i!=1)printf(" ");
    		printf("%d",CBT[i]);
    	}
    	return 0;
    }
    

    Code 02

    #include <iostream>
    #include <vector>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    vector<int> in,level;
    void getLevel(int start, int end, int index) {
    	if(start>end)return;
    	int n=end-start+1;
    	int l=log(n+1)/log(2);//最后一层的层数
    	int leave=n-(pow(2,l)-1); //最后一层叶子结点数
    	//pow(2, l - 1) - 1是除了root结点所在层和最后?层外,左?树的结点个数,pow(2, l - 1) 是l+1
    	//层最多拥有的属于根结点左?树的结点个数,min(pow(2, l - 1), leave)是最后?个结点真正拥有的
    	//属于根结点左?树上的结点个数
    	int root = start+(pow(2,l-1)-1)+min((int)pow(2,l-1),leave);
    	level[index]=in[root];
    	getLevel(start,root-1,2*index+1);
    	getLevel(root+1,end,2*index+2);
    
    }
    int main(int argc,char * argv[]) {
    	int n;
    	scanf("%d",&n);
    	in.resize(n);
    	level.resize(n);
    	for(int i=0; i<n; i++) {
    		scanf("%d",&in[i]);
    	}
    	sort(in.begin(),in.end());
    	getLevel(0,n-1,0);
    	printf("%d",level[0]);
    	for(int i=1; i<n; i++) {
    		printf(" %d",level[i]);
    	}
    	return 0;
    }
    
  • 相关阅读:
    Number Sequence
    不容易系列之(3)—— LELE的RPG难题
    又见回文
    统计元音
    数列
    regular expression
    野兽男孩
    GameStd
    boost and qt compile.
    kde4 + compiz只有两个桌面的问题
  • 原文地址:https://www.cnblogs.com/houzm/p/12333214.html
Copyright © 2011-2022 走看看