zoukankan      html  css  js  c++  java
  • PAT Advanced 1111 Online Map (30) [Dijkstra算法 + DFS]

    题目

    Input our current position and a destination, an online map can recommend several paths. Now your job is to recommend two paths to your user: one is the shortest, and the other is the fastest. It is guaranteed that a path exists for any request.
    Input Specification:
    Each input file contains one test case. For each case, the first line gives two positive integers N (2 <= N <=500), and M, being the total number of streets intersections on a map, and the number of streets, respectively. Then M lines follow, each describes a street in the format:
    V1 V2 one-way length time
    where V1 and V2 are the indices (from 0 to N-1) of the two ends of the street; one-way is 1 if the street is one-way from V1 to V2, or 0 if not; length is the length of the street; and time is the time taken to pass the street.
    Finally a pair of source and destination is given.
    Output Specification:
    For each case, first print the shortest path from the source to the destination with distance D in the format:
    Distance = D: source -> v1 -> … -> destination
    Then in the next line print the fastest path with total time T:
    Time = T: source -> w1 -> … -> destination
    In case the shortest path is not unique, output the fastest one among the shortest paths, which is guaranteed to be unique. In case the fastest path is not unique, output the one that passes through the fewest intersections, which is guaranteed to be unique. In case the shortest and the fastest paths are identical, print them in one line in the format:
    Distance = D; Time = T: source -> u1 -> … -> destination
    Sample Input 1:
    10 15
    0 1 0 1 1
    8 0 0 1 1
    4 8 1 1 1
    3 4 0 3 2
    3 9 1 4 1
    0 6 0 1 1
    7 5 1 2 1
    8 5 1 2 1
    2 3 0 2 2
    2 1 1 1 1
    1 3 0 3 1
    1 4 0 1 1
    9 7 1 3 1
    5 1 0 5 2
    6 5 1 1 2
    3 5
    Sample Output 1:
    Distance = 6: 3 -> 4 -> 8 -> 5
    Time = 3: 3 -> 1 -> 5
    Sample Input 2:
    7 9
    0 4 1 1 1
    1 6 1 1 3
    2 6 1 1 1
    2 5 1 2 2
    3 0 0 1 1
    3 1 1 1 3
    3 2 1 1 2
    4 5 0 2 2
    6 5 1 1 2
    3 5
    Sample Output 2:
    Distance = 3; Time = 4: 3 -> 2 -> 5

    题意

    在线地图中标注了街口和街道
    求出发地到目的地距离最短路径,若最短距离路径有多条,取耗时最少的最短距离路径
    求出发地到目的地耗时最少路径,若耗时最少路径有多条,取经过顶点最少的耗时最少路径

    题目分析

    已知图,顶点,边,边权-距离,边权-耗时
    求距离最短路径,若最短距离路径有多条,取耗时最少的最短距离路径
    求耗时最少路径,若耗时最少路径有多条,取经过顶点最少的耗时最少路径

    解题思路

    • Dijkstra求最短路径,若最短距离路径有多条,选择其中耗时最少的路径
    • dfs回溯路径,并保存到vector dispath
    • Dijkstra求耗时最少路径,若耗时最少路径有多条,取其中经过顶点最少
    • dfs回溯路径,并保存到vector Timepath

    知识点

    比较两个路径是否相同,可以将路径保存于两个vector

    vector<int> path1,path2;
    if(path1==path2){
    //路径相同
    }
    

    Code

    #include <iostream>
    #include <vector>
    using namespace std;
    const int inf=0x7fffffff;
    const int maxn=510;
    int n,m,e[maxn][maxn],w[maxn][maxn],st,fin;
    int dis[maxn],dispre[maxn],Timepre[maxn],visit[maxn],weight[maxn],Time[maxn],NodeNum[maxn];
    vector<int> dispath,Timepath,temppath;
    void dfsdispath(int x) {
    	if(x==-1)return;
    	dispath.push_back(x);
    	dfsdispath(dispre[x]);
    }
    void dfsTimepath(int x) {
    	if(x==-1)return;
    	Timepath.push_back(x);
    	dfsTimepath(Timepre[x]);
    }
    int main(int argc,char * argv[]) {
    	scanf("%d %d",&n,&m);
    	int v1,v2,flag,len,time;
    	for(int i=0; i<m; i++) {
    		scanf("%d %d %d %d %d",&v1,&v2,&flag,&len,&time);
    		e[v1][v2]=len;
    		w[v1][v2]=time;
    		if(flag!=1) {
    			e[v2][v1]=len;
    			w[v2][v1]=time;
    		}
    	}
    	scanf("%d %d",&st,&fin);
    	// 寻找最短距离,耗时最短的路径
    	fill(dis,dis+n,inf);
    	fill(dispre,dispre+n,-1);
    	fill(weight,weight+n,inf);
    	dis[st]=0;
    	weight[st]=0;
    	for(int i=0; i<n; i++) {
    		int u=-1,minn=inf;
    		for(int j=0; j<n; j++) {
    			if(visit[j]==false&&dis[j]<minn) {
    				u=j;
    				minn=dis[j];
    			}
    		}
    		if(u==-1||u==fin)break;
    		visit[u]=true;
    		for(int v=0; v<n; v++) {
    			if(e[u][v]==0||visit[v]==true)continue;
    			if(e[u][v]+dis[u]<dis[v]) {
    				dis[v]=e[u][v]+dis[u];
    				dispre[v]=u;
    				weight[v]=w[u][v]+weight[u];
    			} else if(e[u][v]+dis[u]==dis[v]&&weight[v]>w[u][v]+weight[u]) {
    				// 取所有距离最短中的时间最短路径
    				dispre[v]=u;
    				weight[v]=w[u][v]+weight[u];
    			}
    		}
    	}
    	dfsdispath(fin);
    	fill(Time,Time+n,inf);
    	fill(Timepre,Timepre+n,-1);
    	fill(visit,visit+n,0);
    	fill(NodeNum,NodeNum+n,inf);
    	Time[st]=0;
    	NodeNum[st]=0;
    	for(int i=0; i<n; i++) {
    		int u=-1,minn=inf;
    		for(int j=0; j<n; j++) {
    			if(visit[j]==false&&Time[j]<minn) {
    				u=j;
    				minn=Time[j];
    			}
    		}
    		if(u==-1||u==fin)break;
    		visit[u]=true;
    		for(int v=0; v<n; v++) {
    			if(w[u][v]==0||visit[v]==true)continue;
    			if(w[u][v]+Time[u]<Time[v]) {
    				Time[v]=w[u][v]+Time[u];
    				Timepre[v]=u;
    				NodeNum[v]=1+NodeNum[u];
    			} else if(w[u][v]+Time[u]==Time[v]&&NodeNum[v]>1+NodeNum[u]) {
    				// 取所有距离最短中的时间最短路径
    				Timepre[v]=u;
    				NodeNum[v]=1+NodeNum[u];
    			}
    		}
    	}
    	dfsTimepath(fin);
    	printf("Distance = %d",dis[fin]);
    	if(dispath==Timepath) {
    		printf("; Time = %d: ",Time[fin]);
    	} else {
    		printf(": ");
    		for(int i=dispath.size()-1;i>=0;i--){
    			printf("%d",dispath[i]);
    			if(i!=0)printf(" -> ");
    		}
    		printf("
    Time = %d: ",Time[fin]);
    	}
    	for(int i=Timepath.size()-1;i>=0;i--){
    		printf("%d",Timepath[i]);
    		if(i!=0)printf(" -> ");
    	}
    	return 0;
    }
    

  • 相关阅读:
    ajax异步更新的理解
    Java 中的匿名内部类
    Java 中的方法内部类
    Java 中的静态内部类
    Java 中的成员内部类
    Java 中的 static 使用之静态方法(转)
    构造方法
    成员变量与局部变量的区别
    script标签属性sync和defer
    jsonp原理
  • 原文地址:https://www.cnblogs.com/houzm/p/12378520.html
Copyright © 2011-2022 走看看