zoukankan      html  css  js  c++  java
  • hdu 1114 Piggy-Bank

    Piggy-Bank

                                                                               Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                   Total Submission(s): 11201    Accepted Submission(s): 5657


    Problem Description
    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
     

    Input
    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
     

    Output
    Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
     

    Sample Input
    3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
     

    Sample Output
    The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
     

    Source
     

    简单的全然背包。。

    因为求最小值  注意初始化为最大

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #define M 100000000
    using namespace std;
    struct node{
        int w,v;
    }a[10000];
    int main()
    {
        int cas,e,f,n,i,j,dp[10000];
        cin>>cas;
        while(cas--)
        {
            cin>>e>>f>>n;
            int sum=f-e;
            for(i=0;i<n;i++)
                cin>>a[i].v>>a[i].w;
                dp[0]=0;//不能所有初始化为最大
                for(i=1;i<=sum;i++)
                    dp[i]=M;
            for(i=0;i<n;i++)
                {
                    for(j=a[i].w;j<=sum;j++)
                       {
                           dp[j]=min(dp[j],dp[j-a[i].w]+a[i].v);
                       }
    
                }
                if(dp[sum]==M)
                    cout<<"This is impossible."<<endl;
                else
                cout<<"The minimum amount of money in the piggy-bank is "<<dp[sum]<<"."<<endl;
    
    
        }
        return 0;
    }
    


    版权声明:本文博客原创文章,博客,未经同意,不得转载。

  • 相关阅读:
    用 xampp 在 windows/Linux 下搭建代理服务器
    DOM 元素 属性和方法
    JavaScript入门培训材料(Copy至此以作备份)
    JavaScript 关键字快速匹配
    JS参考书籍
    chrome 阻止跨域操作的解决方法 --disable-web-security
    可输入自动匹配Select——jquery ui autocomplete
    【消息队列】如何保证消息的顺序性
    【消息队列】如何处理消息丢失的问题
    【消息队列】kafka是如何保证消息不被重复消费的
  • 原文地址:https://www.cnblogs.com/hrhguanli/p/4656723.html
Copyright © 2011-2022 走看看