zoukankan      html  css  js  c++  java
  • HDU 2509 Be the Winner

    ^^^转载请注明出处,谢谢合作O(∩_∩)O~

    Be the Winner

    Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
    For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 
    the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

     
    Input
    You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
     
    Output
    If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
     
    Sample Input
    2 2 2 1 3
     
    Sample Output
    No Yes
     
    :此题是尼姆博弈:
    #include<iostream>
    using namespace std;
    int a[110];
    int main()
    {
        int n;
        while(scanf("%d",&n)!=EOF)
        {
            int i;
            int s=0;
            int s1=0;
            for(i=0;i<n;i++)
            {
                cin>>a[i];
                s=s^a[i];
                if(a[i]>=2)
                s1++;
            }        
            if(s==0)//奇异局势
            {
                if(s1>=2)cout<<"No"<<endl;    
                else
                cout<<"Yes"<<endl;
            }
            else//非奇异局势
            {
                if(s1>=1)cout<<"Yes"<<endl;    
                else 
                cout<<"No"<<endl;
            }
        }
        
        return 0;    
    }
  • 相关阅读:
    ASP.NET初识4
    属性
    ASP.NET初识4
    ACCP6.0第九章练习
    ASP.NET初识1
    鼠标指针含义
    ASP.NET初识2
    第三部分
    ASP.NET初识3
    ASP.NET初识5
  • 原文地址:https://www.cnblogs.com/hsqdboke/p/2453079.html
Copyright © 2011-2022 走看看