zoukankan      html  css  js  c++  java
  • HDU 1398 Square Coins

    Square Coins

    Problem Description
    People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
    There are four combinations of coins to pay ten credits: 

    ten 1-credit coins,
    one 4-credit coin and six 1-credit coins,
    two 4-credit coins and two 1-credit coins, and
    one 9-credit coin and one 1-credit coin. 

    Your mission is to count the number of ways to pay a given amount using coins of Silverland.
     
    Input
    The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
     
    Output
    For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
     
    Sample Input
    2 10 30 0
     
    Sample Output
    1 4 27
    :用母函数求解
    #include<iostream>
    using namespace std;
    #include<math.h>
    int main()
    {
        int n;
        int i,j,k,p=0;
        int c[20],a[305],b[305];
        for(i=1;i<=300;i++)
        {
            if(pow((int)(sqrt(i*1.0)),2)==i) //sqrt(i*1.0)
            {
             c[p++]=i;
            }
        }
    
        while(scanf("%d",&n)!=EOF&&n)
        {
            for(i=0;i<=n;i++)
                {
                    a[i]=1;  //1
                    b[i]=0;
                }
            for(i=1;i<p;i++)
            {
                for(j=0;j<=n;j++)
                 for(k=0;k+j<=n;k+=c[i])
                 {
                     b[k+j]+=a[j];
                 }
                 for(j=0;j<=n;j++)
                 {
                     a[j]=b[j];//2
                     b[j]=0;
                 }
            }
            printf("%d\n",a[n]);
        }
        
        return 0;
    }
     
  • 相关阅读:
    QuickSort(Java)
    MergeSort(Java)
    Silverlight中Datagrid添加Button列用于控制单行对象
    二叉搜索树(BST)demo
    svn ignore使用方法
    海量数据处理面试题及解决方法
    Android中的单元测试
    Ubuntu下配置Intellij的Android开发环境
    urlrewrite地址重写之后丢失css和js解决方案
    修改后 简单的 TCP server
  • 原文地址:https://www.cnblogs.com/hsqdboke/p/2455431.html
Copyright © 2011-2022 走看看