zoukankan      html  css  js  c++  java
  • IBM Minus One 简单字符处理

    IBM Minus One

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story ends, in case you want to read the book for yourself :-)

    After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

    Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.


    Input

    The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.


    Output

    For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing 'Z' by 'A'.

    Print a blank line after each test case.


    Sample Input

    2
    HAL
    SWERC


    Sample Output

    String #1
    IBM

    String #2
    TXFSD

    #include<cstdio>
    #include<cstdlib>
    #include<iostream>
    #include<math.h>
    #include<string>
    using namespace std;
    char dic[]={' ','A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z'};
    void _solve(string s)
    {
    	for(int i=0;i<s.length();i++)
    	{		
    		if(s[i]=='Z')  cout<<'A';
    		else {
    		  int j=0;
    		  while(dic[j]!=s[i]) j++;
    		  cout<<dic[j+1];
    		}
    	}
    }
    int main()
    {
    	int n;
    	string str;
    	cin>>n;
    	for(int v=1;v<=n;v++)
    	{
    		cin>>str;
    		cout<<"String #"<<v<<endl;
    		_solve(str);
    		cout<<endl<<endl;
    	}
    	return 0;
    }


    非打表的编码处理方式:
    #include<cstdio>
    #include<cstdlib>
    #include<iostream>
    #include<math.h>
    #include<string>
    using namespace std;
    void _solve(string s)
    {
    	for(int i=0;i<s.length();i++)
    	{		
    		if(s[i]=='Z')  cout<<'A';
    		else cout<<char(s[i]+1);
    	}
    }
    int main()
    {
    	int n;
    	string str;
    	cin>>n;
    	for(int v=1;v<=n;v++)
    	{
    		cin>>str;
    		cout<<"String #"<<v<<endl;
    		_solve(str);
    		cout<<endl<<endl;
    	}
    	return 0;
    }


  • 相关阅读:
    字符编码、文件处理
    列表、字典、元祖、集合
    数字类型、字符串、列表
    学习python的第一天作业
    python基础day2-函数基础2,2019-6-25
    python基础day2-函数基础,2019-6-25
    python基础day2-文件处理,2019-6-25
    python基础day2-流程控制,2019-6-25
    python基础day2-字典类型已内置方法,2019-6-25
    python基础day2-可变类型与不可变类型,2019-6-25
  • 原文地址:https://www.cnblogs.com/hua-dong/p/7603968.html
Copyright © 2011-2022 走看看