zoukankan      html  css  js  c++  java
  • zoj1002 Fire Net

    • Fire Net

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

    The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

    For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

    Sample input:

    4
    .X..
    ....
    XX..
    ....
    2
    XX
    .X
    3
    .X.
    X.X
    .X.
    3
    ...
    .XX
    .XX
    4
    ....
    ....
    ....
    ....
    0
    

    Sample output:

    5
    1
    5
    2
    4
    

    Source: Zhejiang University Local Contest 2001

    初级搜索题,一般人都可以模拟出来。

    可以想成简单的dfs加剪枝,而不是模拟所有情况在判断是否成立。

    代码经过电脑处理后(其实:处理之前也是)感觉不好看


    #include<cstdio>
    #include<cstdlib>
    #include<iostream>
    using namespace std;
    char c[6][6];
    bool f[6][6];
    int n,sum;
    void solve(int x,int y,int ans)
    {
     int i,j;
     bool ok=true;
     if(c[x][y]=='X') ok=false;
     for(i=x-1;i>=1;i--){
      if(c[i][y]=='X') break;
      if(f[i][y]) ok=false;
     }
     for(j=y-1;j>=1;j--){
      if(c[x][j]=='X') break;
      if(f[x][j]) ok=false;
       }
     if(ok) {
      f[x][y]=true;
      if(ans+1>sum) sum=ans+1;
      if(y+1<=n) solve(x,y+1,ans+1);
      else if(x+1<=n) solve(x+1,1,ans+1);
         f[x][y]=false;
     }
     if(y+1<=n) solve(x,y+1,ans); 
     else if(x+1<=n) solve(x+1,1,ans);
     
    }
    int main()
    {
     int i,j;
     while(cin>>n){
         if(n==0) break;
         for(i=1;i<=n;i++)
       for(j=1;j<=n;j++)
        {cin>>c[i][j];f[i][j]=false;}
      sum=0; 
      solve(1,1,0);
      cout<<sum<<endl;
     }
     return 0;
    }

     


  • 相关阅读:
    sqlmap基础使用(以sqli—labs第一关为例)
    IIS、Apache、Nginx日志记录的各个字段内容与含义
    建站+阿里云服务器上传个人制作网页
    SQL server 2005 在Windows server 2003上面的安装
    VMware里kali虚拟机的安装
    第三章web安全基础—http协议及burpsuite基本使用(brupsuite导入证书支持https访问)
    第三章web安全基础—互联网注册网站相关小知识
    第三章web安全基础—IIS发布dvbbs(动网论坛)及SQL2005问题解决
    根据现有目录批量创建文件夹
    PL/SQL通过存储过程为相同数据添加序号
  • 原文地址:https://www.cnblogs.com/hua-dong/p/7603985.html
Copyright © 2011-2022 走看看