zoukankan      html  css  js  c++  java
  • [USACO08JAN]手机网络Cell Phone Network

    [USACO08JAN]手机网络Cell Phone Network

    题目描述

    Farmer John has decided to give each of his cows a cell phone in hopes to encourage their social interaction. This, however, requires him to set up cell phone towers on his N (1 ≤ N ≤ 10,000) pastures (conveniently numbered 1..N) so they can all communicate.

    Exactly N-1 pairs of pastures are adjacent, and for any two pastures A and B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B) there is a sequence of adjacent pastures such that A is the first pasture in the sequence and B is the last. Farmer John can only place cell phone towers in the pastures, and each tower has enough range to provide service to the pasture it is on and all pastures adjacent to the pasture with the cell tower.

    Help him determine the minimum number of towers he must install to provide cell phone service to each pasture.

    John想让他的所有牛用上手机以便相互交流(也是醉了。。。),他需要建立几座信号塔在N块草地中。已知与信号塔相邻的草地能收到信号。给你N-1个草地(A,B)的相邻关系,问:最少需要建多少个信号塔能实现所有草地都有信号。

    输入输出格式

    输入格式:

    • Line 1: A single integer: N

    • Lines 2..N: Each line specifies a pair of adjacent pastures with two space-separated integers: A and B

    输出格式:

    • Line 1: A single integer indicating the minimum number of towers to install

    输入输出样例

    输入样例1:
    5
    1 3
    5 2
    4 3
    3 5

    输出样例#1:
    2
    题解:
    很经典的树形dp,状态为f[i][3]分别表示此节点不选且不能被覆盖,此节点选,此节点不选但能被覆盖三种情况,然后动规方程就很显然了。不过多概述,以下是AC代码:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<cmath>
    #include<algorithm>
    using namespace std;
    int n,m;
    int f[10001][3];
    struct student
    {
        int next,to;
    }edge[30001];
    int head[10001],size;
    void putin(int from,int to)
    {
        size++;
        edge[size].next=head[from];
        edge[size].to=to;
        head[from]=size;
    }
    void dfs(int k,int father)
    {
        int f0=2000000000,f2=0,f1=0,w=0,i,s=0;
        for(i=head[k];i!=-1;i=edge[i].next)
        {
            int y=edge[i].to;
            if(y==father)continue;
            dfs(y,k);
            s=min(f[y][1],f[y][0]);
            w+=s;
            if(f[y][1]-s<f0)f0=f[y][1]-s;
            f1+=min(f[y][1],min(f[y][0],f[y][2]));
            if(f2<2000000000)f2+=f[y][0];
        }
        f[k][1]=f1+1;f[k][2]=f2;
        if(f0==2000000000)f[k][0]=2000000000;
        else f[k][0]=w+f0;
    }
    int main()
    {
        int i,j,from,to;
        cin>>n;
        for(i=1;i<=n;i++)head[i]=-1;
        for(i=1;i<n;i++)
        {
            scanf("%d%d",&from,&to);
            putin(from,to);
            putin(to,from);
        }
        dfs(1,0);
        cout<<min(f[1][0],f[1][1]);
        return 0;
    }
    
    
    
    
    
  • 相关阅读:
    企业级 SpringBoot 教程 (九)springboot整合Redis
    03 网格系统
    02 表单
    01 排版
    客户端调用webSerices
    sql 一行转多行
    sql 多行转一行
    时间差计算 Stopwatch
    sql 游标
    Linq连接查询
  • 原文地址:https://www.cnblogs.com/huangdalaofighting/p/6917309.html
Copyright © 2011-2022 走看看