zoukankan      html  css  js  c++  java
  • HDOJ 2151

    Worm

    Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1727 Accepted Submission(s): 1082


    Problem Description
    自从见识了平安夜苹果的涨价后,Lele就在他家门口水平种了一排苹果树,共有N棵。

    突然Lele发现在左起第P棵树上(从1开始计数)有一条毛毛虫。为了看到毛毛虫变蝴蝶的过程,Lele在苹果树旁观察了很久。虽然没有看到蝴蝶,但Lele发现了一个规律:每过1分钟,毛毛虫会随机从一棵树爬到相邻的一棵树上。

    比如刚开始毛毛虫在第2棵树上,过1分钟后,毛毛虫可能会在第1棵树上或者第3棵树上。如果刚开始时毛毛虫在第1棵树上,过1分钟以后,毛毛虫一定会在第2棵树上。

    现在告诉你苹果树的数目N,以及毛毛刚开始所在的位置P,请问,在M分钟后,毛毛虫到达第T棵树,一共有多少种行走方案数。
     
    Input
    本题目包含多组测试,请处理到文件结束(EOF)。
    每组测试占一行,包括四个正整数N,P,M,T(含义见题目描述,0<N,P,M,T<100)
     
    Output
    对于每组数据,在一行里输出一共的方案数。
    题目数据保证答案小于10^9
     
    Sample Input
    3 2 4 2 3 2 3 2
     
    Sample Output
    4 0
    Hint
    第一组测试中有以下四种走法: 2->1->2->1->2 2->1->2->3->2 2->3->2->1->2 2->3->2->3->2
     
     #include<stdio.h>
     #include<string.h>
     #define N 101
     int dp[N][N];
     int main()
     {
         int i,j;int n,p,m,t;
         while(scanf("%d%d%d%d",&n,&p,&m,&t)==4)
         {
             memset(dp,0,sizeof(dp));
             dp[0][p]=1;
             for(i=1;i<=m;i++)
                 for(j=1;j<=n;j++)
                     dp[i][j]=dp[i-1][j-1]+dp[i-1][j+1];
             printf("%d\n",dp[m][t]);
         }
         return 0;
     }
    
    
    
    
    
    
    
    
    #include <iostream>
    using namespace std;
    
    const int MAX_SIZE = 104;
    
    int main()
    {
        int n,p,m,t;
        int i,j;
        int dp[MAX_SIZE][MAX_SIZE];
        while(cin>>n>>p>>m>>t)
        {
            for(i = 1; i <= n; i++)
                dp[0][i] = 0;//初始化为0种方案
            dp[0][p] = 1;//唯有原始点方案数为1
            for(j = 1; j <= m; j++)
            {
                dp[j][1] = dp[j - 1][2];//最左边特殊处理
                for(i = 2; i < n; i++)
                    dp[j][i] = dp[j - 1][i - 1] + dp[j - 1][i + 1];
                dp[j][n] = dp[j - 1][n - 1];//最右边特殊处理
    
            }
            cout<<dp[m][t]<<endl;
    
        }
        return 0;
    }
    
  • 相关阅读:
    ASP.NET教程4
    ASP.NET教程11
    TreeView Demo
    System.Net.Dns.GetHostByAddress(string) 已经过时
    会员注册实例
    ASP.NET教程2
    多表关联与表值函数
    ASP.NET教程6
    BusinessFrameWork
    ASP.NET教程8
  • 原文地址:https://www.cnblogs.com/hxsyl/p/2570565.html
Copyright © 2011-2022 走看看