zoukankan      html  css  js  c++  java
  • POJ 1363

    Rails
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 18846   Accepted: 7515

    Description

    There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

    The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

    Input

    The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

    The last block consists of just one line containing 0.

    Output

    The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

    Sample Input

    5
    1 2 3 4 5
    5 4 1 2 3
    0
    6
    6 5 4 3 2 1
    0
    0

    Sample Output

    Yes
    No
    
    Yes
    //我的第一个C++栈模板,值得纪念下 ,输入格式搞得我头大 
    #include<cstdio>
    #include<stack>
    #include<cstring>
    #include<cstdlib>
    using namespace std;
    int main()
    {
        int i,j,k,T;
        int num,flag;
        while(scanf("%d",&T),T)
        {
            flag=0;//必须再次初始化为0 
            while(1)
            {
                stack <int> s;//定义成局部的。每次使用,便会重新清空 
                int temp=1;
                s.push(temp);
                for(i=1;i<=T;i++)
                {   
                    scanf("%d",&num);
                    //printf("num=%d\n",num);
                    if(0==num)
                    {
                        flag=1;
                        break;
                    }
                    if(s.empty())
                    {
                        temp++;
                        s.push(temp);
                    }
                    int top=s.top();
                    while(top!=num)
                    {
                        if(temp==T)
                           break;
                        temp++;
                        s.push(temp);
                        top=s.top();
                    }
                    if(top==num)
                        s.pop();
                }
                if(flag)
                    break;
                if(s.empty())
                    puts("Yes");
                else
                    puts("No");
            }
            printf("\n");
        }
        system("pause"); 
        return 0;
    }
                    
                
                    
                    
                
            
            
            
    
  • 相关阅读:
    一、Git安装
    三、ASP.NET Core 部署Linux 第二篇(Core SDK 3.1)
    .net core 3.1
    一、GitHub创建仓并提交项目
    二、GitHub创建仓并提交项目
    django xdmin使用
    python logging一个通用的使用模板
    一则小脚本(工作中用)
    jmeter 压测最近的心得体会
    jmeter 分布式实战
  • 原文地址:https://www.cnblogs.com/hxsyl/p/2620472.html
Copyright © 2011-2022 走看看