zoukankan      html  css  js  c++  java
  • TOJ 1601

    1601.   Box of Bricks
    Time Limit: 1.0 Seconds   Memory Limit: 65536K
    Total Runs: 5007   Accepted Runs: 1950



    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. "Look, I've built a wall!", he tells his older sister Alice. "Nah, you should make all stacks the same height. Then you would have a real wall.", she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

    Input

    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 ≤ n ≤ 50 and 1 ≤ hi ≤ 100.

    The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

    The input is terminated by a set starting with n = 0. This set should not be processed.


    Output

    For each set, first print the number of the set, as shown in the sample output. Then print the line "The minimum number of moves is k.", where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

    Output a blank line after each set.


    Sample Input

    6
    5 2 4 1 7 5
    0
    


    Sample Output

    Set #1
    The minimum number of moves is 5.
    
    //大于平均值的部分加和 ,简单题目,学习vector 
    //AC
    #include <iostream>
    #include <cstdlib>
    #include <algorithm>
    #include <vector>
    using namespace std;
    int main()
    {
        int i,j,k,T;
        int flag = 1;//必须开在while外,并且初始化0 
        while(cin>>T,T)
        {
            int sum = 0;
            vector <int > v;
            for(i=1;i<=T;i++)
            {
                int temp;
                cin>>temp;
                v.push_back(temp);
                sum += temp;
            }
            int aver = sum / v.size();
            int ans = 0;
            for(i=0;i<v.size();i++)
                if(v.at(i)>aver)
                    ans += v.at(i) - aver;
            //if(flag>1)
                
            cout<<"Set #"<<flag<<endl;
            cout<<"The minimum number of moves is "<<ans<<"."<<endl;
            cout<<endl;
            flag++;
            v.clear();
        }
        //system("pause");
        return 0;
    }
     
     
     //个人认为,应该
     #include <iostream>
    #include <cstdlib>
    #include <algorithm>
    #include <vector>
    using namespace std;
    int main()
    {
        int i,j,k,T;
        int flag = 1;//必须开在while外,并且初始化0 
        while(cin>>T,T)
        {
            int sum = 0;
            vector <int > v;
            for(i=1;i<=T;i++)
            {
                int temp;
                cin>>temp;
                v.push_back(temp);
                sum += temp;
            }
            int aver = sum / v.size();
            int ans = 0;
            for(i=0;i<v.size();i++)
                if(v.at(i)>aver)
                    ans += v.at(i) - aver;
            if(flag>1)
                cout<<endl;  
            cout<<"Set #"<<flag<<endl;
            cout<<"The minimum number of moves is "<<ans<<"."<<endl;
            flag++;
            v.clear();
        }
        //system("pause");
        return 0;
    }
                
                
            
    
  • 相关阅读:
    解题报告:luogu P1156
    解题报告:AT3605
    矩阵乘法与斐波那契数列
    九、模块
    八、异常
    七、文件处理
    六、对象和内存分析
    五、函数和内存分析
    四、控制语句
    三、序列
  • 原文地址:https://www.cnblogs.com/hxsyl/p/2640674.html
Copyright © 2011-2022 走看看