zoukankan      html  css  js  c++  java
  • HDU 1711

    Number Sequence

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 6111    Accepted Submission(s): 2744


    Problem Description
    Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
     
    Input
    The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
     
    Output
    For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
     
    Sample Input
    2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
     
    Sample Output
    6 -1
     
    //kmp,裸题 
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <cstdlib>
    using namespace std;
    int b[10005],a[1000010];
    int next[10005];
    int m,n;
    void get()
    {
        memset(next,0,sizeof(next));
        int i,j;
        i = 0;
        j = -1;
        next[0] = -1;
        while(i<m)
        {
            if(j==-1||b[i]==b[j])
            {
                i++;
                j++;
                next[i] = j;
            }
            else
                j = next[j];
        }
    }
    int kmp()
    {
        int i=0,j=0;
        while(i<n&&j<m)
        {
            if(j==-1||a[i]==b[j])
            {
                i++;
                j++;
            }
            else
            {
                j = next[j];
            }
        }
        if(j==m)
            return i-j+1;
        else
            return -1;
    }   
    int main()
    {
        int i,j,k,T;
        scanf("%d",&T);
        while(T--)
        {
            memset(b,0,sizeof(b));
            memset(a,0,sizeof(a));
            scanf("%d%d",&n,&m);
            for(i=0;i<n;i++)
                scanf("%d",a+i);
            for(i=0;i<m;i++)
                scanf("%d",b+i);
            get();
            //cout<<next[0]<<endl;
            //system("pause");    
            int pos = kmp();
            printf("%d\n",pos);
        }
        return 0;
    }
            
            
                  
        
    
  • 相关阅读:
    java pojo类
    web(一)
    java通过配置文件(Properties类)连接Oracle数据库代码示例
    java数组排序(插入排序、冒泡排序、选择排序)与递归 代码示例
    匿名内部类
    java反射机制
    ubuntu安装kvm流程
    squid代理服务问答
    ftp nfs samba比较
    Samba服务问答
  • 原文地址:https://www.cnblogs.com/hxsyl/p/2644014.html
Copyright © 2011-2022 走看看