zoukankan      html  css  js  c++  java
  • poj 3684

    Physics Experiment
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 784   Accepted: 266   Special Judge

    Description

    Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is Hmeters above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

    Simon wants to know where are the N balls after T seconds. Can you help him?

    In this problem, you can assume that the gravity is constant: g = 10 m/s2.

    Input

    The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers NHRT.
    1≤ N ≤ 100.
    1≤ H ≤ 10000
    1≤ R ≤ 100
    1≤ T ≤ 10000

    Output

    For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

    Sample Input

    2
    1 10 10 100
    2 10 10 100

    Sample Output

    4.95
    4.95 10.20

    Source

     
    方法类似POJ ants 那题。
     
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <cmath>
    
    using namespace std;
    
    const int MAX = 105;
    const double g = 10.0;
    int N,H,R,T;
    double y[MAX];
    
    double cal(int T) {
            if(T < 0) return H;
            double t = sqrt(2 * H / g);
            int k = (int) T / t;
            if(k % 2 == 0) {
                    double d = T - k * t;
                    return H - g * d * d / 2;
            } else {
                    double d = k * t + t - T;
                    return H - g * d * d / 2;
            }
    }
    
    
    void solve() {
            for(int i = 0; i < N; ++i) {
                    y[i] = cal(T - i);
            }
    
            sort(y ,y + N);
            for(int i = 0; i < N; ++i) {
                    printf("%.2f%c",y[i] + 2 * R * i / 100.0,i + 1 == N ? '
    ' : ' ');
            }
    }
    int main()
    {
        int C;
        //freopen("sw.in","r",stdin);
        scanf("%d",&C);
        while(C--) {
                scanf("%d%d%d%d",&N,&H,&R,&T);
    
                solve();
        }
       // cout << "Hello world!" << endl;
        return 0;
    }
  • 相关阅读:
    qt中线程的使用方法
    QT中定时器的使用方法
    Common Lisp学习笔记(八)
    Common Lisp学习笔记(七)
    Common Lisp学习笔记(六)
    vim使用笔记
    Django学习笔记:urlresolvers
    python closures and decorators
    规范命名:变量名的力量
    eclipse openGL glut运行环境配置
  • 原文地址:https://www.cnblogs.com/hyxsolitude/p/3633791.html
Copyright © 2011-2022 走看看