zoukankan      html  css  js  c++  java
  • HDU 4707:Pet

    Pet

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2248    Accepted Submission(s): 1098


    Problem Description
    One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.
     

    Input
    The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.
     

    Output
    For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
     

    Sample Input
    1 10 2 0 1 0 2 0 3 1 4 1 5 2 6 3 7 4 8 6 9
     

    Sample Output
    2
     

    Source
     

    迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

    #include <iostream>
    #include <cmath>
    #include <stdio.h>
    #include <string>
    #include <cstring>
    #include <map>
    #include <set>
    #include <vector>
    #include <stack>
    #include <queue>
    #include <iomanip>
    #include <algorithm>
    #define maxn 100010
    using namespace std;
    struct P
    {
        int num;
        int dis;
    };
    int vis[maxn];
    vector<int> v[maxn];
    int N,D;
    void init()
    {
        for(int i=0; i<=N; i++)
            v[i].clear();
    }
    int bfs()
    {
        int ans=0;
        P tmp,n;
        queue<P> q;
        while(!q.empty())
            q.pop();
        tmp.dis=0;
        tmp.num=0;
        q.push(tmp);
        memset(vis,0,sizeof(vis));
        while(!q.empty())
        {
            n=q.front();
            q.pop();
            if(n.dis>D)ans++;
            for(int i=0; i<(int)v[n.num].size(); i++)
            {
                if(vis[v[n.num][i]]==0)
                {
                    vis[v[n.num][i]]=1;
                    tmp.dis=n.dis+1;
                    tmp.num=v[n.num][i];
                    q.push(tmp);
                }
            }
        }
        return ans;
    }
    int main()
    {
        int T;
        int x,y;
        cin>>T;
        while(T--)
        {
            scanf("%d%d",&N,&D);
            init();
            for(int i=0; i<N-1; i++)
            {
                scanf("%d%d",&x,&y);
                v[x].push_back(y);
            }
            cout<<bfs()<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    Well, that was fun! An adventure in WCF, SSL, and Host Headers (转)
    算法还重要吗?
    Silverlight测试——利用Ranorex实现数据驱动测试
    MSSQl分布式查询
    Silverlight 4 CHM中文离线文档已提供下载
    快速打包你的应用程序——Inno Setup
    IE 9 Beta 测试Bug
    IE 9 Bate 泄露版
    Windows PowerShell初体验——.NET对象支持
    多样化实现Windows Phone 7本地数据库访问<2>
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989350.html
Copyright © 2011-2022 走看看