zoukankan      html  css  js  c++  java
  • YTU 2441: C++习题 复数类--重载运算符2+

    2441: C++习题 复数类--重载运算符2+

    时间限制: 1 Sec  内存限制: 128 MB
    提交: 847  解决: 618

    题目描述

    定义一个复数类Complex,重载运算符“+”,使之能用于复数的加法运算。参加运算的两个运算量可以都是类对象,也可以其中有一个是整数,顺序任意。例如,c1+c2,i+c1,c1+i均合法(设i为整数,c1,c2为复数)。编写程序,分别求两个复数之和、整数和复数之和。

    输入

    两个复数 
    一个复数和一个整数 
    一个整数和一个复数

    输出

    两个复数之和、复数和整数之和,整数和复数之和。

    样例输入

    3 4 5 -10
    3 4 5
    5 3 4
    

    样例输出

    c1+c2=(8.00,-6.00i)
    c1+i=(8.00,4.00i)
    i+c1=(8.00,4.00i)
    

    提示

    前置代码及类型定义已给定如下,提交时不需要包含,会自动添加到程序前部



    /* C++代码 */

    #include <iostream>

    #include <iomanip>

    using namespace std;

    class Complex

    {

    public:

        Complex()

        {

            real=0;

            imag=0;

        }

        Complex(double r,double i)

        {

            real=r;

            imag=i;

        }

        Complex operator+(Complex &c2);

        Complex operator+(int &i);

        friend Complex operator+(int&,Complex &);

        void display();

    private:

        double real;

        double imag;

    };





    主函数已给定如下,提交时不需要包含,会自动添加到程序尾部



    /* C++代码 */



    int main()

    {

        double real,imag;

        cin>>real>>imag;

        Complex c1(real,imag);

        cin>>real>>imag;

        Complex c2(real,imag);

        cout<<setiosflags(ios::fixed);

        cout<<setprecision(2);

        Complex c3=c1+c2;

        cout<<"c1+c2=";

        c3.display();

        int i;

        cin>>real>>imag;

        cin>>i;

        c3=Complex(real,imag)+i;

        cout<<"c1+i=";

        c3.display();

        cin>>i;

        cin>>real>>imag;

        c1=Complex(real,imag);

        c3=i+c1;

        cout<<"i+c1=";

        c3.display();

        return 0;

    }

    迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

    #include <iostream>
    #include <iomanip>
    using namespace std;
    class Complex
    {
    public:
        Complex()
        {
            real=0;
            imag=0;
        }
        Complex(double r,double i)
        {
            real=r;
            imag=i;
        }
        Complex operator+(Complex &c2);
        Complex operator+(int &i);
        friend Complex operator+(int&,Complex &);
        void display();
    private:
        double real;
        double imag;
    };
    Complex Complex:: operator +(Complex &c2)
    {
        Complex c;
        c.real=real+c2.real;
        c.imag=imag+c2.imag;
        return c;
    }
    Complex Complex:: operator +(int &i)
    {
        Complex c;
        c.real=real+i;
        c.imag=imag;
        return c;
    
    }
    Complex operator + (int &i,Complex &c2)
    {
        Complex c;
        c.real=i+c2.real;
        c.imag=c2.imag;
        return c;
    }
    void Complex::display()
    {
        cout<<"("<<real<<","<<imag<<"i)"<<endl;
    }
    int main()
    {
        double real,imag;
        cin>>real>>imag;
        Complex c1(real,imag);
        cin>>real>>imag;
        Complex c2(real,imag);
        cout<<setiosflags(ios::fixed);
        cout<<setprecision(2);
        Complex c3=c1+c2;
        cout<<"c1+c2=";
        c3.display();
        int i;
        cin>>real>>imag;
        cin>>i;
        c3=Complex(real,imag)+i;
        cout<<"c1+i=";
        c3.display();
        cin>>i;
        cin>>real>>imag;
        c1=Complex(real,imag);
        c3=i+c1;
        cout<<"i+c1=";
        c3.display();
        return 0;
    }
    

  • 相关阅读:
    埋点
    go 搭建web服务
    go的常见操作
    Zeus资源调度系统介绍
    支付系统中热点账户的性能问题
    redis
    集成Spring-Boot与gRPC,grpc-spring-boot-starter
    Spring Cloud灰度发布之Nepxion Discovery
    Spring Cloud Stream
    通过消息总线Spring Cloud Bus实现配置文件刷新(使用Kafka或RocketMQ)
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989443.html
Copyright © 2011-2022 走看看