zoukankan      html  css  js  c++  java
  • HDU 1045:Fire Net

    Fire Net

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 8797    Accepted Submission(s): 5082


    Problem Description
    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
     

    Input
    The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
     

    Output
    For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
     

    Sample Input
    4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
     

    Sample Output
    5 1 5 2 4
     

    Source
     

    Recommend
    We have carefully selected several similar problems for you:  1016 1010 1175 1241 1312 
     

    迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    char map[5][5];
    int k[5][5];
    int n,ab;
    bool ok(int a,int b)
    {
        for(int i=b-1; i>=0&&map[a][i]!='X'; i--)
            if(k[a][i])return false;
        for(int i=a-1; i>=0&&map[i][b]!='X'; i--)
            if(k[i][b])return false;
        return true;
    }
    void huisu(int a,int b,int m)
    {
        for(int i=a; i<n; i++)
        {
            if(i>a)b=-1;
            for(int j=b+1; j<n; j++)
            {
                if(map[i][j]=='X')continue;
                if(ok(i,j))
                {
                    k[i][j]=1;
                    huisu(i,j,m+1);
                    k[i][j]=0;
                }
            }
        }
        ab=ab<m?m:ab;
    }
    int main()
    {
        while(cin>>n&&n)
        {
            ab=0;
            memset(map,0,sizeof(map));
            memset(k,0,sizeof(k));
            getchar();
            for(int i=0; i<n; i++)
                gets(map[i]);
            for(int i=0; i<n; i++)
                for(int j=0; j<n; j++)
                {
                    if(map[i][j]=='X')continue;
                    k[i][j]=1;
                    huisu(i,j,1);
                    k[i][j]=0;
                }
            cout<<ab<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    Excel常用公式函数之文本查找某个符号
    Excel常用公式函数之日期格式转换成文本格式
    Excel常用公式函数之数据是否相等
    Excel常用公式函数之数据筛选、数据统计
    Excel常用公式函数之字符串拼接、字符串连接
    Excel常用公式函数之MID文本提取
    Excel常用技巧汇总
    netty面试题整理
    mqtt通配符订阅
    SQL | substring_index 字符串拆分
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989541.html
Copyright © 2011-2022 走看看