zoukankan      html  css  js  c++  java
  • HDU 1050:Moving Tables

    Moving Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 26457    Accepted Submission(s): 8757


    Problem Description
    The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



    The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



    For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
     

    Input
    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
     

    Output
    The output should contain the minimum time in minutes to complete the moving, one per line.
     

    Sample Input
    3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
     

    Sample Output
    10 20 30
     

    Source
     

    Recommend
    We have carefully selected several similar problems for you:  2037 1051 1052 1789 1045 
     


    迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

    #include <iostream>
    #include <string.h>
    using namespace std;
    int main()
    {
        int M;
        cin>>M;
        while(M--)
        {
            int N,z,x,ma=0,i,j;
            int count[201];
            cin>>N;
            memset(count,0,sizeof(count));
            for(i=1; i<=N; i++)
            {
                cin>>z>>x;
                z = (z-1)/2;
                x = (x-1)/2;
                if(x<z)swap(z,x);
                for(j=z; j<=x; j++)count[j]++;
            }
            for(i=0; i<200; i++)
                if(count[i] > ma) ma=count[i];
            cout<<ma*10<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    Redis学习第八课:Redis高级实用特性(二)
    Redis学习第八课:Redis高级实用特性(一)
    Redis学习第七课:键值命令和服务器命令
    Redis学习第六课:Redis ZSet类型及操作
    Redis学习第五课:Redis Set类型及操作
    Redis学习第四课:Redis List类型及操作
    (error) MISCONF Redis is configured to save RDB snapshots, but is currently not able to persist on disk.
    Clickhouse单机及集群部署详解
    一致性模型及一致性协议
    HBase存储及读写原理介绍
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989552.html
Copyright © 2011-2022 走看看