zoukankan      html  css  js  c++  java
  • POJ 2505:A multiplication game

    A multiplication game
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 5624   Accepted: 2813

    Description

    Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

    Input

    Each line of input contains one integer number n.

    Output

    For each line of input output one line either 
    Stan wins. 
    or 
    Ollie wins. 
    assuming that both of them play perfectly.

    Sample Input

    162
    17
    34012226

    Sample Output

    Stan wins.
    Ollie wins.
    Stan wins.
    

    Source

    Waterloo local 2001.09.22

    你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

    #include <iostream>
    using namespace std;
    int main()
    {
        double n;
        while(cin>>n)
        {
            while(n > 18)n/=18;
            if(n <= 9)cout << "Stan wins." << endl;
            else cout << "Ollie wins." << endl;
        }
        return 0;
    }
    

  • 相关阅读:
    Go-day01
    M1-Flask-Day2
    M1-Flask-Day1
    Tornado基于MiddleWare做中间件
    SqlAlchenmy基本使用
    PV、UV、UIP、VV、CPC、CPM、RPM、CTR解释
    Celery笔记
    Celery 分布式任务队列快速入门
    库操作
    Django cache
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989579.html
Copyright © 2011-2022 走看看