zoukankan      html  css  js  c++  java
  • POJ 2260:Error Correction

    Error Correction
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 6014   Accepted: 3886

    Description

    A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property: 
    1 0 1 0
    
    0 0 0 0
    
    1 1 1 1
    
    0 1 0 1

    The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2. 
    Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt. 

    Input

    The input will contain one or more test cases. The first line of each test case contains one integer n (n<100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.

    Output

    For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print "Corrupt".

    Sample Input

    4
    1 0 1 0
    0 0 0 0
    1 1 1 1
    0 1 0 1
    4
    1 0 1 0
    0 0 1 0
    1 1 1 1
    0 1 0 1
    4
    1 0 1 0
    0 1 1 0
    1 1 1 1
    0 1 0 1
    0
    

    Sample Output

    OK
    Change bit (2,3)
    Corrupt
    

    Source

    你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

    #include <iostream>
    using namespace std;
    int main()
    {
        int a[105][105],b[105],c[105],i,j,n;
        while(cin >> n,n)
        {
            for(i = 0; i<n; i++)
                for(j = 0; j<n; j++)
                    cin >> a[i][j];
            for(i = 0; i<n; i++)
            {
                b[i] = 0;
                for(j = 0; j<n; j++)
                    b[i]+=a[i][j];
            }
            for(i = 0; i<n; i++)
            {
                c[i] = 0;
                for(j = 0; j<n; j++)
                    c[i]+=a[j][i];
            }
            int sum1=0,sum2 = 0,flag1,flag2;
            for(i = 0; i<n; i++)
                if(b[i]%2)
                    sum1++,flag1 = i;
            for(i = 0; i<n; i++)
                if(c[i]%2)  sum2++,flag2 = i;
            if(sum1 > 1 || sum2>1)cout << "Corrupt" << endl;
            else if(!sum1 && !sum2)cout << "OK" << endl;
            else  cout << "Change bit (" << flag1+1 << "," << flag2+1 << ")" << endl;
        }
        return 0;
    }


  • 相关阅读:
    数据提交
    Python网页信息抓取
    Python语法学习
    Elasticsearch5.x 升级-插件
    LeetCode 33 搜索旋转排序数组
    按之字形顺序打印二叉树
    股票的最大利润
    LeetCode 1143 最长公共子序列
    对称的二叉树
    两个链表的第一个公共结点
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989585.html
Copyright © 2011-2022 走看看