zoukankan      html  css  js  c++  java
  • YTU 2903: A--A Repeating Characters

    2903: A--A Repeating Characters

    时间限制: 1 Sec  内存限制: 128 MB
    提交: 50  解决: 30

    题目描述

    For this problem,you will write a program that takes a string of characters,S,and creates a new string of characters,T,with each character repeated R times.That is,R copies of the first character of S,followed by R copies of the second character of S,and so on.Valid characters for S are the QR
    Code “alphanumeric” characters:
         0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ$%*+-. /:

    输入

    The first line of input contains a single integer P,(1<=P<=1000),which is the number of data sets that follow. Each data set is single line of input consisting of the data set number N,followed by a space,followed by the repeat count R,(1<=R<=8),followed by a space ,followed by the string S.The length of string S will always be at least one and  no more than 20 characters.All the characters will be from the set of characters shown above.

    输出

    For each data set there is one line of output. It contains the data set number,
    N, followed by a single apace which is then followed by the new string T,which is made of each character in S repeated R times.

    样例输入

    2
    1 3 ABC
    2 5 /HTP
    

    样例输出

    1 AAABBBCCC
    2 /////HHHHHTTTTTPPPPP
    


    im0qianqian_站在回忆的河边看着摇晃的渡船终年无声地摆渡,它们就这样安静地画下黄昏画下清晨......可怜

    #include <string.h>
    #include <stdio.h>
    int main()
    {
        int P,N,num,i=0,j,k;
        char c[20];
        scanf("%d",&P);
        for(k=0; k<P; k++,i=0,puts(""))
        {
            scanf("%d%d %s",&N,&num,c);
            printf("%d ",N);
            for(; c[i]!=''; i++)
                for (j=1; j<=num; j++)
                    printf("%c",c[i]);
        }
        return 0;
    }
    


  • 相关阅读:
    psp4
    一维循环数组最大子数组求解
    psp3
    psp2
    求二维数组最大连续子数组
    计算连续最大子数组问题
    psp1
    关于30道题目问题
    Java 文件操作
    java iterator
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989666.html
Copyright © 2011-2022 走看看