zoukankan      html  css  js  c++  java
  • POJ3278-Catch That Cow

    Description

    Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

    * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
    * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

    If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

    Input

    Line 1: Two space-separated integers: N and K

    Output

    Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

    Sample Input

    5 17

    Sample Output

    4

    思路:
    这个题目又开发广搜的一个新的功能:求出图中两点的最短距离
    这个证明是通过搜索树得到的,想象一个点可以扩展为其他三个点,那么被扩展出来的这三个点到最初始点的那个距离就是最短的,因为如果不是最短的,那么这三个点在之前就会出现
    其实质就是一个最优路线上的每一个被扩展出的点都是最优的。

    #include <iostream>
    #include <cstring>
    #include <queue>
    #define MAX 100007
    #define INF 0x7fffffff
    using namespace std;
    
    int n,k;
    int vis[MAX];
    int dis[MAX];
    
    int bfs()
    {
    	queue<int> q;
    	q.push(n);
    	int next;
    	while(!q.empty())
    	{
    		int tmp = q.front();
    		q.pop();
    		for(int i = 1;i <= 3;i++) {
    			if(i == 1) next = tmp-1;
    			else if(i == 2) next = tmp+1;
    			else next = tmp*2;
    			if(next<0 || next>MAX) 
    				continue;
    			if(!vis[next]) {
    				vis[next] = 1;
    				dis[next] = dis[tmp]+1;
    				q.push(next);
    			}
    			if(next == k) 
    				return dis[k];
    		}
    	}
    }
    
    int main()
    {
    	while(cin>>n>>k) {
    		memset(vis,0,sizeof(vis));
    		vis[n] = 1; 
    		if(n >= k) 
    			cout<<n-k<<endl;
    		else cout<<bfs()<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    调用 验证码
    始终居中的弹出层
    jq常用
    ThinkPHP redirect 方法
    session 的生成和删除
    1355:字符串匹配问题(strs)
    1348:【例49】城市公交网建设问题
    1357:车厢调度(train)
    1358:中缀表达式值(expr)
    1351:【例412】家谱树
  • 原文地址:https://www.cnblogs.com/immortal-worm/p/5136452.html
Copyright © 2011-2022 走看看