zoukankan      html  css  js  c++  java
  • POJ-2240

    Arbitrage
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 19063   Accepted: 8069

    Description

    Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

    Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

    Input

    The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
    Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

    Sample Input

    3
    USDollar
    BritishPound
    FrenchFranc
    3
    USDollar 0.5 BritishPound
    BritishPound 10.0 FrenchFranc
    FrenchFranc 0.21 USDollar
    
    3
    USDollar
    BritishPound
    FrenchFranc
    6
    USDollar 0.5 BritishPound
    USDollar 4.9 FrenchFranc
    BritishPound 10.0 FrenchFranc
    BritishPound 1.99 USDollar
    FrenchFranc 0.09 BritishPound
    FrenchFranc 0.19 USDollar
    
    0
    

    Sample Output

    Case 1: Yes
    Case 2: No

    思路:
    抽象出来这题就是要求一个图的最大环,仍然用Floyd算法
    要注意下G数组的对角线的值都要是1

    #include <iostream>
    #include <cstring>
    #include <map>
    using namespace std;
    
    map<string,int> money;
    double G[37][37];
    int n,m;
    
    void Floyd()
    {
        for(int k = 1;k <= n;k++)
            for(int i = 1;i <= n;i++)
                for(int j = 1;j <= n;j++)
                    if(G[i][j] < G[i][k]*G[k][j])
                        G[i][j] = G[i][k]*G[k][j];
    }
    
    int main()
    {
        int countt = 0;
        while(cin>>n && n)
        {
            string tmp;
            for(int i = 1;i <= n;i++)
            {
                cin>>tmp;
                money.insert(make_pair(tmp,i));
                G[i][i] = 1;
            }
            cin>>m;
            string t1,t2;
            double t;
            for(int i = 1;i <= m;i++)
            {
                cin>>t1>>t>>t2;
                G[money[t1]][money[t2]] = t;
            }
            Floyd();
            int flag = 0;
            for(int i = 1;i <= n;i++)
                if(G[i][i] > 1) {
                    flag = 1;
                    break;
                }
            if(flag) 
                cout<<"Case "<<++countt<<": Yes"<<endl;
            else 
                cout<<"Case "<<++countt<<": No"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Ubuntu修改源
    设置Div多行文本超出时,以省略号代替
    通过修改 Apache 的配置文件 htaccess 文件实现自定义404页面
    图片压缩的几种工具(初稿)
    DFA算法 处理屏蔽词库
    Xcode版本太低引发的bug,xcode各种版本下载方式详解
    Cocos2dx3.11.1Android播放视频,后台 黑屏,无法记忆播放bug修改
    cocos2d-x视频控件VideoPlayer的用户操作栏进度条去除(转载)
    python操作文件案例二则
    Live2d-cocos2dx教程(一)例子搭建及运行
  • 原文地址:https://www.cnblogs.com/immortal-worm/p/5187630.html
Copyright © 2011-2022 走看看