zoukankan      html  css  js  c++  java
  • UVa 12096 The SetStack Computer

     

    Description

    Background from Wikipedia: "Set theory is a branch of mathematics created principally by the German mathematician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play the role of a foundational theory in modern mathematics, in the sense of a theory invoked to justify assumptions made inmathematics concerning the existence of mathematical objects (such as numbers or functions) and their properties. Formal versions of set theory also have a foundational role to play as specifying a theoretical ideal of mathematical rigor in proofs."

    Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets instead of numbers. The initial Set-Stack Alpha is under construction, and they need you to simulate it in order to verify the operation of the prototype.

    The computer operates on a single stack of sets, which is initially empty. After each operation, the cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT, and ADD.
    • PUSH will push the empty set {} on the stack.
    • DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
    • UNION will pop the stack twice and then push the union of the two sets on the stack.
    • INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
    • ADD will pop the stack twice, add the first set to the second one, and then push the resulting set on the stack.
    For illustration purposes, assume that the topmost element of the stack is
    A = {{}, {{}}}

    and that the next one is
    B = {{}, {{{}}}}.

    For these sets, we have |A| = 2 and |B| = 2. Then:
    • UNION would result in the set { {}, {{}}, {{{}}} }. The output is 3.
    • INTERSECT would result in the set { {} }. The output is 1.
    • ADD would result in the set { {}, {{{}}}, {{},{{}}} }. The output is 3.

    Input

    An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each test case contains the number of operations 0 ≤ N ≤ 2 000. Then follow N lines each containing one of the five commands. It is guaranteed that the SetStack computer can execute all the commands in the sequence without ever popping an empty stack.

    Output

    For each operation specified in the input, there will be one line of output consisting of a single integer. This integer is the cardinality of the topmost element of the stack after the corresponding command has executed. After each test case there will be a line with *** (three asterisks).

    Sample Input

    2
    9
    PUSH
    DUP
    ADD
    PUSH
    ADD
    DUP
    ADD
    DUP
    UNION
    5
    PUSH
    PUSH
    ADD
    PUSH
    INTERSECT

    Sample Output

    0
    0
    1
    0
    1
    1
    2
    2
    2
    ***
    0
    0
    1
    0
    0
    ***
     
     
     
    解析:运用STL可方便地解决这个问题。用vector来存储各个不同的集合,运用map将集合映射为vector中相应的下标。集合的操作UNION、INTERSECT、ADD可分别用algorithm中的set_union、set_intersection以及set自带的insert完成,按题意运用stack模拟栈操作即可。
     
     
     
    #include <iostream>
    #include <set>
    #include <map>
    #include <vector>
    #include <stack>
    #include <algorithm>
    using namespace std;
    
    map<set<int>, int> id;
    map<set<int>, int>::iterator it;
    vector<set<int> > v;
    
    int getID(set<int> x)
    {
        it = id.find(x);
        if(it != id.end())
            return it->second;
        v.push_back(x);
        return id[x] = v.size()-1;
    }
    
    int main()
    {
        int T, n;
        cin>>T;
        while(T--){
            cin>>n;
            id.clear();
            v.clear();
            stack<int> s;
            string op;
            while(n--){
                cin>>op;
                if(op[0] == 'P')
                    s.push(getID(set<int>()));
                else if(op[0] == 'D')
                    s.push(s.top());
                else{
                    set<int> t1 = v[s.top()]; s.pop();
                    set<int> t2 = v[s.top()]; s.pop();
                    set<int> t;
                    if(op[0] == 'U'){
                        set_union(t1.begin(), t1.end(), t2.begin(), t2.end(), inserter(t, t.begin()));
                        s.push(getID(t));
                    }
                    else if(op[0] == 'I'){
                        set_intersection(t1.begin(), t1.end(), t2.begin(), t2.end(), inserter(t, t.begin()));
                        s.push(getID(t));
                    }
                    else if(op[0] == 'A'){
                        t2.insert(getID(t1));
                        s.push(getID(t2));
                    }
                }
                cout<<v[s.top()].size()<<endl;
            }
            cout<<"***"<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    发现一个github上特别优秀的面试准备资料
    坠吼的大哥的博客
    [BJDCTF 2nd]假猪套天下第一
    [网鼎杯 2020 朱雀组]phpweb
    [GWCTF 2019]我有一个数据库
    [BJDCTF2020]ZJCTF,不过如此
    [GXYCTF2019]禁止套娃
    洛谷
    [ZJCTF 2019]NiZhuanSiWei
    蓝帽杯决赛-爆炒腰花-WP
  • 原文地址:https://www.cnblogs.com/inmoonlight/p/5701630.html
Copyright © 2011-2022 走看看