zoukankan      html  css  js  c++  java
  • AcWing 1128. 信使 单源最短路

    地址 https://www.acwing.com/problem/content/description/1130/

    战争时期,前线有 n 个哨所,每个哨所可能会与其他若干个哨所之间有通信联系。
    
    信使负责在哨所之间传递信息,当然,这是要花费一定时间的(以天为单位)。
    
    指挥部设在第一个哨所。
    
    当指挥部下达一个命令后,指挥部就派出若干个信使向与指挥部相连的哨所送信。
    
    当一个哨所接到信后,这个哨所内的信使们也以同样的方式向其他哨所送信。信在一个哨所内停留的时间可以忽略不计。
    
    直至所有 n 个哨所全部接到命令后,送信才算成功。
    
    因为准备充足,每个哨所内都安排了足够的信使(如果一个哨所与其他 k 个哨所有通信联系的话,这个哨所内至少会配备 k 个信使)。
    
    现在总指挥请你编一个程序,计算出完成整个送信过程最短需要多少时间。
    
    输入格式
    第 1 行有两个整数 n 和 m,中间用 1 个空格隔开,分别表示有 n 个哨所和 m 条通信线路。
    
    第 2 至 m+1 行:每行三个整数 i、j、k,中间用 1 个空格隔开,表示第 i 个和第 j 个哨所之间存在 双向 通信线路,且这条线路要花费 k 天。
    
    输出格式
    一个整数,表示完成整个送信过程的最短时间。
    
    如果不是所有的哨所都能收到信,就输出-1。
    
    数据范围
    1≤n≤100,
    1≤m≤200,
    1≤k≤1000
    输入样例:
    4 4
    1 2 4
    2 3 7
    2 4 1
    3 4 6
    输出样例:
    11

    算法1
    单源最短路模板

    C++ 代码

    #include <iostream>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    
    const int N = 300;
    
    int g[N][N];
    bool st[N];
    int dist[N];
    int n, m;
    
    void dij()
    {
        memset(dist, 0x3f, sizeof dist);
        dist[1] = 0;
    
        for (int i = 0; i < n; i++) {
            int t = -1;
            for (int j = 1; j <= n; j++) {
                if (!st[j] && (t == -1 || dist[t] > dist[j])) {
                    t = j;
                }
            }
            st[t] = true;
    
            for (int j = 1; j <= n; j++) {
                dist[j] = min(dist[j], dist[t] + g[t][j]);
            }
        }
    
        return;
    }
    
    int main()
    {
        cin >> n >> m;
        memset(g, 0x3f, sizeof g);
        while (m--) {
            int a, b, c;
            cin >> a >> b >> c;
            g[a][b] = (c);
            g[b][a] = (c);
        }
    
        dij();
        int ans = -1;
        for (int i = 1; i <= n; i++) {
            ans = max(dist[i], ans);
        }
        if (ans == 0x3f3f3f3f) ans = -1;
        cout << ans << endl;
        return 0;
    }
    作 者: itdef
    欢迎转帖 请保持文本完整并注明出处
    技术博客 http://www.cnblogs.com/itdef/
    B站算法视频题解
    https://space.bilibili.com/18508846
    qq 151435887
    gitee https://gitee.com/def/
    欢迎c c++ 算法爱好者 windows驱动爱好者 服务器程序员沟通交流
    如果觉得不错,欢迎点赞,你的鼓励就是我的动力
    阿里打赏 微信打赏
  • 相关阅读:
    LeetCode "Palindrome Partition II"
    LeetCode "Longest Substring Without Repeating Characters"
    LeetCode "Wildcard Matching"
    LeetCode "Best Time to Buy and Sell Stock II"
    LeetCodeEPI "Best Time to Buy and Sell Stock"
    LeetCode "Substring with Concatenation of All Words"
    LeetCode "Word Break II"
    LeetCode "Word Break"
    Some thoughts..
    LeetCode "Longest Valid Parentheses"
  • 原文地址:https://www.cnblogs.com/itdef/p/13233079.html
Copyright © 2011-2022 走看看