zoukankan      html  css  js  c++  java
  • 挑战程序设计竞赛 习题 poj 3050 Hopscotch

    地址 https://vjudge.net/problem/POJ-3050

    The cows play the child's game of hopscotch in a non-traditional way. 
    Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.
    They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid.
    They hop again (same rules) to a digit (potentially a digit already visited). With a total of five intra
    -grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). Determine the count of the number of distinct integers that can be created in this manner. Input * Lines 1..5: The grid, five integers per line Output * Line 1: The number of distinct integers that can be constructed Sample Input 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 2 1 1 1 1 1 1 Sample Output 15 Hint OUTPUT DETAILS: 111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111,
    and 212121 can be constructed.
    No other values are possible.

    代码 

    #include <iostream>
    #include <set>
    #include <vector>
    
    using namespace std;
    
    int arr[6][6];
    set<vector<int>> ss;
    
    int addx[4] = {1,-1,0,0};
    int addy[4] = {0,0,-1,1};
    
    void dfs(int x,int y,vector<int>& v)
    {
      if(v.size() == 6){
        ss.insert(v); return;
      }
       v.push_back(arr[x][y]);
        for(int i =0;i < 4;i++){
          int newx = x+ addx[i];
          int newy = y +addy[i];
            if(newx>=0 && newx<5 && newy>=0 && newy <5){
                 dfs(newx,newy,v);
              }
    
        }      
     
       
      v.pop_back();
       return ;
    }
    
    int main(){
    for(int i =0; i < 5;i++){
    for(int j = 0; j<5;j++){
     cin >> arr[i][j];
    }
    }
    
    for(int i =0; i < 5;i++){
    for(int j = 0; j<5;j++){
       vector<int> v;
       dfs(i,j,v);
    }
    }
    cout << ss.size() << endl;
     return 0;
    }
  • 相关阅读:
    媒介管理系统权限设计方案
    document.ready和window.onload区别,顺带jQuery的ready方法
    nvm管理node版本
    async await一些小结
    Git学习
    详解JavaScript中的正则表达式
    JavaScript中的事件循环机制跟函数柯里化
    前端面试遇到的问题
    ES6在工作中会用到的核心知识点讲解
    JavaScript中的事件委托机制跟深浅拷贝
  • 原文地址:https://www.cnblogs.com/itdef/p/14288654.html
Copyright © 2011-2022 走看看