zoukankan      html  css  js  c++  java
  • Common Subsequence_公共子序列

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 49   Accepted Submission(s) : 25

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

    Sample Input

    abcfbc abfcab
    programming contest 
    abcd mnp
    

    Sample Output

    4
    2
    0

    dp[i][j]记录的是0到i-1、j-1共有多少个相同

    #include<iostream>
    #include<string.h>
    using namespace std;
    int dp[2005][2005];
    int max(int a,int b)
    {
        return a>b?a:b;
    }
    int main()
    {
        char a[2005],b[2005];
        while(cin>>a>>b)
        {
            int len1=strlen(a);
            int len2=strlen(b);
            memset(dp,0,sizeof(dp));
            for(int i=1;i<=len1;i++)
                for(int j=1;j<=len2;j++)
            {
                if(a[i-1]==b[j-1])
                    dp[i][j]=dp[i-1][j-1]+1;
                else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
            cout<<dp[len1][len2]<<endl;
        }
    
        return 0;
    }
    

      

  • 相关阅读:
    PS转换图片——我教你
    通过Ajax——异步获取相关问题解答
    Spring的线程安全
    Spring MVC的工作机制
    Annotation的语法和使用
    Spring Bean的生命周期
    浅谈Spring
    Spring的事务管理
    行为型模式
    结构型模式
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5738371.html
Copyright © 2011-2022 走看看