zoukankan      html  css  js  c++  java
  • Human Gene Functions_最大公共序列(插空版)

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 18   Accepted Submission(s) : 13

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

    A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

    A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

    Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 

    Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix. 

    For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned: 

    AGTGAT-G 
    -GT--TAG 

    In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

    * denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

    Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

    AGTGATG 
    -GTTA-G 

    This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

    Input

    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100. 

    Output

    The output should print the similarity of each test case, one per line. 

    Sample Input

    2 
    7 AGTGATG 
    5 GTTAG 
    7 AGCTATT 
    9 AGCTTTAAA 
    

    Sample Output

    14 
    21 

    不错的方法*****

    题意:给定两个字符串 s1 和 s2 ,在两个串中都可以插入空格,使两个串的长度最后相等,然后开始匹配,怎样插入空格由匹配规则得到的值最大。

    分析:LCS的变形
    dp[i][j]=max(dp[i-1][j-1]+mp[ s1[i] ][ s2[j] ] , dp[i-1][j]+mp[ s1[i] ][ '-' ] , dp[i][j-1]+mp[ '-' ][ s2[j] ] );
    确定下一个dp[i][j]的三种情况(i-1位和j-1位匹配则接下去i和j位匹配,i-1和j位匹配则i位与空位匹配,i和j-1位匹配则空位与j位匹配)取最大值的情况。
     
    边界:(s1和s2从下标1开始读取)dp[0][0]=0; dp[i][0]=dp[i-1][0] + mp[ s1[i] ][ '-' ] ; dp[0][i]=dp[0][i-1] + mp[ '-' ][ s2[i] ];
     
    **:dp[i][j] = dp[i-1][j]+mp[ s1[i] ][ '-' ] 表示 s1[i-1] 与 s2[j] 匹配 于是 s1[i] 就只能和 ‘-’(空格)匹配了
     
    小技巧:match[][] 的使用
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    const int N=150;
    int dp[N][N],mp[N][N];
    char s1[N],s2[N];
    void init()
    {
        int A,C,G,T;
        A='A';
        C='C';
        G='G';
        T='T';
        mp[A][A]=mp[C][C]=mp[G][G]=mp[T][T]=5;
        mp[A][C]=mp[C][A]=mp[A][T]=mp[T][A]=mp[T][' ']=mp[' '][T]=-1;
        mp[A][G]=mp[G][A]=mp[C][T]=mp[T][C]=mp[G][T]=mp[T][G]=mp[' ']['G']=mp['G'][' ']=-2;
        mp[A][' ']=mp[' '][A]=mp[G][C]=mp[C][G]=-3;
        mp[C][' ']=mp[' '][C]=-4;
    }
    int max(int a,int b)
    {
        return a>b?a:b;
    }
    int main()
    {
        init();
        int t;
        cin>>t;
        while(t--)
        {
            int n,m;
            scanf("%d %s",&n,s1+1);
            scanf("%d %s",&m,s2+1);
            dp[0][0]=0;
            for(int i=1; i<=n; i++)
                dp[i][0]=dp[i-1][0]+mp[s1[i]][' '];
            for(int i=1; i<=m; i++)
                dp[0][i]=dp[0][i-1]+mp[' '][s2[i]];
            for(int i=1; i<=n; i++)
            {
                for(int j=1; j<=m; j++)
                {
                    dp[i][j]=max(dp[i-1][j]+mp[s1[i]][' '],dp[i][j-1]+mp[' '][s2[j]]);
                    dp[i][j]=max(dp[i][j],dp[i-1][j-1]+mp[s1[i]][s2[j]]);
                }
            }
    
            cout<<dp[n][m]<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    波松分酒问题 C++求最优解. Anthony
    Effective STL 条款7 Anthony
    Effective STL 条款16 Anthony
    数据库设计经验之谈[转载]
    C#递归在dropdownlist显示树状
    多域名同主机js转向
    ASP.NET中常用的26个优化性能方法
    域名解析、子域名、cname别名指向、MX记录、泛域名与泛解析、域名绑定、域名转向
    C#数据库递归构造treeview树形结构
    ASP.NET多种方式生成高质量缩略图
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5742934.html
Copyright © 2011-2022 走看看