zoukankan      html  css  js  c++  java
  • King's Cake

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/65536K (Java/Other)
    Total Submission(s) : 4   Accepted Submission(s) : 3

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    It is the king's birthday before the military parade . The ministers prepared a rectangle cake of size n×m(1n,m10000) . The king plans to cut the cake himself. But he has a strange habit of cutting cakes. Each time, he will cut the rectangle cake into two pieces, one of which should be a square cake.. Since he loves squares , he will cut the biggest square cake. He will continue to do that until all the pieces are square. Now can you tell him how many pieces he can get when he finishes.

    Input

    The first line contains a number T(T1000), the number of the testcases.

    For each testcase, the first line and the only line contains two positive numbers n,m(1n,m10000).

    Output

    For each testcase, print a single number as the answer.

    Sample Input

    2
    2 3
    2 5

    Sample Output

    3
    4
    
    #include<iostream>
    #include<string.h>
    using namespace std;
    int solve(int n,int m)
    {
        int t;
        if(n<m) {t=n,n=m,m=t;}
        if(n==m) return 0;
        else return solve(n-m,m)+1;
    }
    int main()
    {
        int t,n,m;
        cin>>t;
        while(t--)
        {
            cin>>n>>m;
            int ans=solve(n,m)+1;
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    sql处理数据库锁的存储过程
    SQL语句
    partial 函数
    map函数
    python命令行上下 退格,左右键不能用
    postgresql 在linux上的源码安装
    python字典操作
    根据key存不存在查询json
    精典博文
    python解析XML之ElementTree
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5752896.html
Copyright © 2011-2022 走看看