zoukankan      html  css  js  c++  java
  • Box of Bricks_贪心

    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 20586   Accepted: 8300

    Description

    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. "Look, I've built a wall!", he tells his older sister Alice. "Nah, you should make all stacks the same height. Then you would have a real wall.", she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help? 


    Input

    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100. 

    The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height. 

    The input is terminated by a set starting with n = 0. This set should not be processed. 

    Output

    For each set, first print the number of the set, as shown in the sample output. Then print the line "The minimum number of moves is k.", where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

    Output a blank line after each set.

    Sample Input

    6
    5 2 4 1 7 5
    0

    Sample Output

    Set #1
    The minimum number of moves is 5.
    #include<iostream>
    #include<string.h>
    #include<stdio.h>
    using namespace std;
    const int N=55;
    int a[N];
    int main()
    {
        int n,cas=0;
        while(cin>>n,n)
        {
            int sum=0;
            cas++;
            for(int i=1;i<=n;i++)
            {
                cin>>a[i];
                sum+=a[i];
            }
            int ave=sum/n;
            int ans=0;
            for(int i=1;i<=n;i++)
            {
                if(a[i]>ave)
                {
                    ans+=a[i]-ave;
                }
            }
            printf("Set #%d
    The minimum number of moves is %d.
    
    ",cas,ans);
        }
        return 0;
    }
  • 相关阅读:
    类的再理解
    关于网络配置和zmp以及json
    PCL 库安装
    Ros学习注意点
    Ros集成开发环境配置
    《TCP/IP详解卷1:协议》第3章 IP:网际协议(1)-读书笔记
    《Effective C++》第1章 让自己习惯C++-读书笔记
    《TCP/IP详解卷1:协议》第2章 链路层-读书笔记
    《TCP/IP详解卷1:协议》第1章 概述-读书笔记
    C++内存分配与对象构造的分离
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5796159.html
Copyright © 2011-2022 走看看